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Digital Signage v3.0 Quick Start

Preface 
Digital signage is among the fastest-growing markets for visual communications. Unlike 
traditional e-mail, web and print notices, it has the power to quickly deliver dynamic messages 
and media that don't get lost in the clutter. VBrick's Digital Signage captures your audience's 
attention wherever they gather: lobbies, reception areas, foyers, break rooms, classrooms, call 
centers, retail kiosks, transportation hubs, or manufacturing floors. Because communications 
can be delivered to any number of displays—plasmas, LCDs, televisions, room signs, PCs, 
Macs, and mobile devices—the possibilities are unlimited. Using a browser-based interface, 
you can access the entire Digital Signage toolkit on the web to create, schedule and deliver 
important announcements and alerts across your entire network. This means that 
communicators with minimal design or technology experience can create engaging messages, 
choosing from an extensive background library, or easily importing graphics and media from 
other sources. They then select the playlist and location to display the message, and schedule 
the time, date and duration of playback. 

Organization 

The information in this document is arranged as follows:

Chapter Description

. Introduction Describes the application and explains the different features 
available with Standard, Professional, and Enterprise versions.

. Create Provides a detailed explanation of how to create bulletins, 
tickers, playlists, and crawl lists.

. Now Playing Explains how to use the Now Playing functionality to view and 
manage playlists, crawl lists, streams, video feeds, etc.

. Manage Explains how to manage all of your content including 
templates, tickers, events, video files, graphic files, etc.

. Configure Explains how to configure adapters for use with bulletins and 
playlists. These include both standard and purchased adapters.

. System Tools Explains how to changes passwords and modes, and how to 
view alarms, status reports, and error logs.

. VBrick Desktop Explains how to install and use this desktop application to 
create layouts and templates and import large files.

. Channel Player 
Configuration

Explains how to configure and manage the Signage Players.

. Other Tasks Explains how to install PowerPoint, how to back up the 
database, and other common tasks. 

. Glossary Provides a glossary of Digital Signage terminology. 

EMS Data Adapter Explains how to integrate event data from Dean Evans EMS 
software.
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Getting Help

If you can't find the information you need in this document, or from your reseller, you can 
contact VBrick Support Services on the web, by e-mail, or by calling 1-203 303-0222. For 
faster service, be sure to have your VBrick product serial number or support contract 
number. Support Services can usually answer your technical questions in 24 business hours or 
less. Note that all VBrick documentation is posted on the web. For more information about 
any VBrick product, go to www.vbrick.com/documentation 

Related Publications 

VBrick Digital Signage Release Notes 

VBrick H.264 Encoder Admin Guide 

VBrick Windows Media Encoder Admin Guide 

VBrick VOD-WM Server Admin Guide 

VBrick VOD-W Server Admin Guide 

Font Conventions

Arial bold is used to describe dialog boxes and menu choices, for example: Start > All 
Programs > VBrick

Courier fixed-width font is used for scripts, code examples, or keyboard commands.

Courier bold fixed-width font is used for user input in scripts, code examples, or keyboard 
commands. 

This bold black font is used to strongly emphasize important words or phrases. 

Folder names and user examples in text are displayed in this sans serif font. 

User input in text is displayed in this bold sans serif font. 

Italics are used in text to emphasize specific words or phrases. 

Safety Precautions
There is always a danger present when using electronic equipment. Unexpected high voltages 
can be present at unusual locations in defective equipment and signal distribution systems. 
Become familiar with the equipment that you are working with and observe the following 
safety precautions.

Mass Alert Notification Explains how to display alert messages on all Digital Signage 
endpoints.

Wayfinding Explains how to use the "wayfinding" Digital Signage mapping 
application.

Note When reading this documentation, you may notice that the terms "signage player" 
and "channel player" are used synonymously and refer to the same device. The terms 
"content server" and "content manager" are also used synonymously. 

Chapter Description

http://www.vbrick.com/support/index.asp
mailto:support@vbrick.com
http://www.vbrick.com/documentation/index.html
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• Every precaution has been taken in the design of your Digital Signage system to ensure 
that it is as safe as possible. However, safe operation depends on you.

• Always be sure your equipment is in good working order. Ensure that all points of 
connection are secure to the chassis and that protective covers are in place.

• Never work alone when working in hazardous conditions. Always have another person 
close by in case of an accident.

• Always refer to the manual for safe operation. If you have a question about the 
application or operation call VBrick for assistance.

• Never allow your equipment to be exposed to water or high moisture environments. If 
exposed to a liquid, remove power safely and send the unit to be serviced by a qualified 
technician. 

Environmental Goals 
At VBrick, we believe that running our company with a "green" conscience is good for the 
environment and good for business and that environmental awareness is an important part of 
the value we deliver to our customers. We recognize our responsibilities to our customers, 
partners, and employees, and also to the communities in which we live and work. We believe 
that the same ethics and principles that guide our daily business decisions should be applied 
to the environment as well. We design superior quality, high performance, and energy-
efficient products and are continually looking for  ways to conserve energy and reduce waste. 
As a company, we look for ways to be environmentally friendly in designing our products and 
operating our facilities, and by choosing partners and suppliers who are committed to 
sustainable development. You can help by recycling batteries and other consumables and by 
finding new and better ways to protect and preserve our environment. If you have ideas or 
suggestions that will help to reinforce our commitment to these goals, please let us know. 
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Product Description 
Digital Signage is a sophisticated network-based bulletin display system for use with 
televisions, monitors, plasma displays, and other display devices. Through a common Web 
browser, anyone connected to your local area network (LAN) can create, upload, manage and 
deliver creative and powerful messages. Digital Signage goes beyond the usability of a 
traditional character generator or bulletin display system by opening access to virtually an 
unlimited number of people via your LAN or even through the Internet. Users gain access to 
a secure Digital Signage server with a valid user name and password, and all display 
submittals are approved by a system administrator before being displayed.

Figure 1.  Typical Display with Ticker, Images, and Streaming Video 

Important Note The term "signage player" refers to the standalone devices that feed audio 
and video signals to LCDs, plasma displays, and other player devices. The terms "signage 
player" and "channel player" are used synonymously. We are transitioning to new 
terminology and there may still be legacy references to "channel player" in the application 
and in the online help.
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This manual will guide you on setting up the Digital Signage product(s) you have purchased. 
You will find that all the Digital Signage server hardware and software is already installed—
you just need to configure the server for your organization and connect it to your computer 
and video networks. VBrick Digital Signage has three main components: the Digital Signage 
software, a Content Manager server, and one or more Signage Players. Authorized users can 
access the Content Manager and software tools via an easy-to-use web interface to create, 
manage, and schedule time-sensitive content. Messages are grouped into named playlists for 
easy management. These playlists are published to selected Signage Players which feed 
display devices at scheduled times and intervals. You can distribute messages (bulletins) to 
flat-panel LCDs and plasma displays, to set top boxes and TVs, and to desktops as pop-up 
messages. Here is basically how it works: 

1. Users create bulletins and schedule them into playlists. 
2. Content is updated on the Content Manager and sent to the Signage Players. 
3. The Signage Players push content out to flat panels, set top boxes, or other displays.

Product Features

• Stream video to Digital Signage players
• Take the output of Digital Signage player and encode as one video stream to deliver to 

PCs, Macs, Set Top Boxes, and mobile devices
• Display multiple content formats – Video, Audio, Flash, Web, RSS feeds
• Use easy creation and scheduling tools with an extensive background library
• Import custom graphics, backgrounds and wallpapers
• Directly import PowerPoint with transitions
• Point to dynamic graphics on the web (weather, traffic, etc.)
• Include live video feeds or streams in overlay windows
• Include Flash interactivity and charting for data visualization
• Display data feeds (weather, stocks, etc.) as tickers or bulletins
• Create informative tickers
• Add audio to visual messages
• Set and use templates for controlled formatting
• Schedule a variety of multi-window layouts
• Customize and save layout templates
• Manage user roles and security settings
• Access sophisticated management tools for system oversight
• Use Alert Mode to override current messages and deliver emergency communications

Content Manager and Signage Players

The Digital Signage system includes a Content Manager and one or more Signage Players. 
The Content Manager hosts the Digital Signage application software, system database, and 
the browser-based user interface. The Content Manager does not provide bulletin display 
outputs—this is the role of the Signage Players. 

Signage Players run the Digital Signage software (on a custom embedded version of 
Windows XP) and provide HDMI video and analog audio connections on the back of the 
player. Support for additional locations and/or channels of bulletin display are accomplished 
by adding Signage Players. The Digital Signage Standard application supports up to 2 Signage 
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Players; the Professional application supports up to 50; and the Enterprise application 
supports up to 4000 Signage Players. 

The Content Manager is a standard 19-inch 2 RU (rack unit) server; the Signage Players have 
a smaller form factor similar to a small, cable TV set top box. The Content Manager runs 
Windows Server 2008 (32-bit only) or optionally Windows 2003 Server Standard Edition. 
The Signage Players run a custom embedded version of Windows XP Professional. 

Figure 2.  Typical Digital Signage Layout 

Note As a standard practice the system automatically reboots itself once each week. The 
Boot Schedule option lets you set the day and time or you can choose to disable the 
reboot entirely. See Configure > Content Settings > Boot Schedule on page 36 for 
more information. 
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Figure 3.  Application "Welcome" Page

Product CD

The Digital Signage Product CD has documentation and software. The documentation 
includes this Quick Start Guide as well as the Online Help which you can also access directly 
from the application. If you purchased a hardware/software combination, all Digital Signage 
software is installed on the Content Manager and the Signage Players. If you purchased 
Digital Signage as a software-only option, you will need to install the Content Manager 
software on your own hardware. (Note that the Signage Player is a preconfigured, standalone 
device and must be purchased "as is" from VBrick.) Detailed hardware specifications and 
installation instructions for the Content Manager are contained in the Digital Signage Release 
Notes. 

System Installation

If you purchased the complete hardware and software solution from VBrick, the Digital 
Signage system will consist of Content Manager software running on a standalone web server 
and one or more standalone Signage Players. You are also required to purchase Digital 
Signage installation services and training. If you purchased the software only version of 
Digital Signage and VEMS, you will need to purchase and configure your own Content 
Manager hardware and then install the VBrick software from the Digital Signage Product CD. 
Hardware specifications, equipment setup, and detailed software installation instructions are 
provided in the Digital Signage Release Notes. 

 To start using Digital Signage:

1. Set up the Content Manager hardware and configure the device for your network. See the 
setup instructions in the Release Notes.

2. Set up the Signage Player(s) and configure the device(s) for your network. See the setup 
instructions in the Release Notes.
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3. Optional. Install Desktop Messenger on user desktops if you purchased this option. This 
setup is typically performed by individual users. The software is available from the web 
interface under System Tools.

4. Optional. Install VBrick Desktop on selected user desktops. This standalone desktop 
application has tools typically used by those who will be creating layouts and templates. 
The software is available from the web interface under System Tools. 

Feature Licenses

Digital Signage installs all current features in the application and the licensing mechanism 
controls whether or not a particular feature is available for use. The license key you received 
is valid for all of the features and options you purchased. If you add additional options, you 
will receive a new license. See Activating a License Key on page 62 for help activating a 
license. To see exactly what licenses are currently installed on your system, go to System 
Tools > Error Logs (or Status) and click on the System Configuration Report link. Contact 
your VBrick Sales representative or certified reseller to purchase additional feature licenses. 
When purchasing a license, you will be asked to provide the Volume ID of the server on 
which the Content Manager is running and the original sales order number under which the 
licenses were purchased. 

 To get the Volume ID of the Content Manager server: 

1. Login to the Content Manager server as administrator|vbrick. 
2. Click on Start > Run, type cmd in the Run window, and click OK. 
3. At the DOS prompt type dir and press Enter

4. Find the line that says Volume Serial Number is nnnn-nnnn 
5. Note the Volume ID as all lower case without the hyphen. 

Software Versions
As explained below, VBrick Digital Signage is available in three different software versions. 

Table 1.  Software Versions

Version Description

Standard Scalable and manageable, Standard is ideal for small businesses and 
manufacturing environments (< 150 users), K–12 school districts, 
government organizations, student unions, single channel cable access 
stations, and standalone hotel and restaurant venues. Standard supports 
Digital Signage only. 

Professional Professional is perfect for college and university campuses, medium business 
and manufacturing environments (> 250 users), hotel and restaurant 
franchises, call centers, churches, hospitals, hospitality venues and multi-
channel cable access stations. Professional supports Digital Signage and 
Desktop Messenger.

Enterprise Enterprise offers a unified communications solution for large campuses, 
extensive K–12 school districts, state and federal government, large business 
and manufacturing environments (> 500 users), transportation networks, 
retail spaces, and hotel chains. Enterprise supports Digital Signage and 
Desktop Messenger. 
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Product Features by Version

Depending on your signage requirements, VBrick Digital Signage is available in three 
versions: Standard, Professional, and Enterprise. Each has different standard, optional, and 
upgrade features. For an explanation of symbols, see "Legend" below table.

Table 2.  Product Features by Version

Content Manager Features Standard Professional Enterprise

Signage Player Support up to 2 up to 50 up to 4000 

Playlists per Signage Player 4 8 12

Tickers per Signage Player 2 4 8

Signage Player Snapshots S S S

Software Features and Subscriptions 

Active Directory Support - O S 

RSS Data Feeds (subscription) O O O 

Delayed Delivery Data Management - - S 

Desktop Messenger - O O 

Mass Alert Notification O O O

Dynamic Graphic Link - S S 

Free Weather Updates S S S 

Message Priority - - S 

N-Tier Publishing - - S 

Player, Playlist and Ticker Grouping - - S 

Proxy Server Awareness - O S 

Public Web Page S S S 

Push / Pull Content Distribution - - S 

Video Stream Management S S S 

Ad Tracking and Reporting O O O

Dean Evans EMS Data Adapter O O O

Mass Alert Notification O O O

Signage Player Features 

Video Streaming Option S S S

Web Page Bulletin O O O 

Flash Playback S S S 

Graphics S S S 

QuickTime Playback S S S 

Legend
S Standard
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Application Description 
Digital Signage is a web-based application that runs in a browser. Every web page includes an 
expandable menu for easy navigation. Each page is divided in to two parts: a navigation tree 
on the left and the workspace on the right. The current topic in the navigation "tree" is 
highlighted in bold for easy reference. Dropdown menus are used in the workspace for 
convenient selection. Helpful hints and prompts appear in red text at the top right. Clicking 
the Help Button (?) in the upper right of the screen will open the Digital Signage help system 
in a separate window. Digital Signage is shipped with the following default user accounts. The 
"System Administrator" has access to all Digital Signage features and functions. It is always a 
good idea to change the default passwords (see Change Password on page 43) when 
configuring the application. 

Table 3.  Default User Accounts

Login 

 To login to Digital Signage:

1. Launch a browser, and depending on how your system is configured, enter the IP address 
or host name of your Content Server, for example:

http://<content_server_ip_address>/digital signage 

2. When the login window is displayed, enter the default administrator name (admin) and 
password (admin). 

3. When the Welcome page is displayed, it is strongly recommended that you change the 
passwords for the default user accounts (see Table 3). To change the password, go to 
System Tools > Change Password. 

Navigation Tree

As shown on the "Welcome" page in Figure 3, the navigation tree on the left includes all of 
the tools you will need to create, manage, and deliver state-of-the-art multimedia playlists. 
These tools are fully explained in following pages of this Quick Start Guide.

O    Optional
- Not compatible
(n) Additional units available

Account Name Password Role

administrator admin System Administrator

default admin Content Approver

Welcome Shows all bulletins and crawls requiring approval. 

Create Used to create various types of bulletins and tickers.
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Getting Started

The following steps show the basic workflow you will need to follow to create a fully 
functional Digital Signage bulletin similar to the one shown in Figure 1. Each of these steps 
are described in detail on the referenced pages.

 To get started using Digital Signage:

1. Setup the Content Manager and Signage Player hardware as explained in the Release 
Notes. 

2. Optional. If you did not purchase a hardware/software combination (or are upgrading), 
install the Content Manager software from the Product CD. See the Release Notes on the 
Product CD for hardware specification and installation details.

3. Login to the application by entering the IP address/digital signage or host name/
digital signage in your browser.

4. Configure any adapters you may have purchased (see Configuring Adapters on page 33). 
5. Configure Content Settings. These include Playlists, Crawl Lists, Aspect Ratios, etc. See 

Content Settings on page 35 for details. 
6. Configure Security. Define Users, Roles, and Security Policy (see Security on page 35).
7. Add a Signage Player to the configuration (see Channel Player Configuration on 

page 55.)
8. Install VBrick Desktop on a local PC if necessary. See Installing the Desktop Tools on 

page 45.
9. Assign a layout to your Signage Player(s) using the Display Layout Editor (see Display 

Layout Editor on page 49).
10. Create a bulletin (see Creating Bulletins on page 11). 

Import Lets you import images or stored video clips and PowerPoint 
presentations.

Now Playing Used to review and manage playlists, crawl lists, video clips, and 
streams to see what's playing and when.

Manage Lets you manage the content library. This includes approvals, content, 
templates, tickers, event schedules, images, video clips, etc. The 
graphic, video, and audio files in the library are used when creating 
bulletins and playlists. Use the Media Import link to add graphic, 
video, and audio files to the content library. 

Schedule Lets you manage all of the bulletins you (and others) create. The 
options you have on this screen depend upon your privileges (as 
assigned by a system administrator) and the folders you view. The 
screen is divided into two main sections: Folders and Bulletins. 
Folders in the folders section group bulletins. The bulletins section 
shows bulletins that are not grouped into folders.

Configure Lets you configure adapters, Signage Players, and other system 
resources. These tasks are typically performed by an administrator.

System Tools Lets an administrator change Passwords and Modes, and view Alarms, 
Status Reports, and Error Logs.

Logout This option is useful if you want to logout and then log back in as a 
different user with different authoring/managing privileges. 
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11. Add a ticker.
12. Import an optional image. 
13. Schedule the bulletin. (Note: Bulletin approval may be required if the user creating the 

bulletin is not assigned a Content Approver or System Administrator role. If the bulletin 
requires approval, someone with that role must approve before it will play.) 

Figure 4.  Digital Signage Network Diagram † 

Online Help

If you need help with any page in Digital Signage click on the question mark icon in the 
upper right corner of the page. This will display specific, context-sensitive information 

about the fields on that page. You can also click on Screens to find information about any 
screen in the application.

†  This diagram shows the "VBrick Enhanced Digital Signage" solution. The Signage Player can also output 
to a large format display (for example a plasma, LCD, or other device). 
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Figure 5.  Online Help Pages
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Overview
When you login and launch the application, the read-only "Welcome" page will show only 
those bulletins and crawls (tickers) to which you have access—access and approval for 
bulletins and tickers is controlled by the administrator. To view or manage an existing 
bulletin, for example, go to the Now Playing or Manage pages. To create a new bulletin or 
ticker, click on the Create. As shown in Table 2 on page 6 the number of playlists and crawl 
lists is determined by which software package you purchased. Bulletins and tickers are 
scheduled to playlists and crawl lists respectively. Multiple bulletins and tickers are 
concatenated into playlists and crawl lists which run in linear order from first to last. They 
can be rearranged or modified as necessary. Playlists and crawl lists are scheduled to a 
content block on the Signage Player. Content blocks are associated with Signage Players on 
the Configure > Channel Players page. 

VBrick's Digital Signage solution provides standard backgrounds and templates that make it 
easy to quickly develop signage content. You will also find an enhanced set of Theme Packs 
on the Product CD that was shipped with this product. These Theme Packs include 
color-coordinated backgrounds, layout templates, and layout wallpapers that let you develop 
more impressive looking signage content from standard templates. If you want further 
customized templates and backgrounds, the Branded Theme Pack option is available. This 
will provide custom color templates, layouts, and bulletins with your company logo inserted. 
For additional enhancements (including applications such as interactive "wayfinding" maps) 
VBrick's Custom Content Creation services are available. Contact your certified reseller or a 
VBrick Sales representative for more information.

Creating Bulletins
As shown in Table 4, Digital Signage lets you create a variety of bulletins that can be used for 
different purposes. They are all similar with some important distinctions. Note that you can 
associate audio files with a bulletin only if audio files have been added to the audio library 

Note Some Digital Signage features and functions are enabled by license. This means that, 
depending on the licenses you purchased, you may not see some of the features and 
functions described in this document. For example, if you do not have a license for 
Desktop Messenger, you will not see the Desktop Messenger in the navigation bar
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using Manage > Audio Files. When creating a bulletin use the Preview button to view the most 
current rendering of your bulletin. The screen automatically refreshes to provide an updated 
preview each time you click the button. The Cancel navigation button lets you cancel back to 
the previous function (or screen) or you can select Next to proceed to scheduling the bulletin 
(if you have scheduling privileges) or back to the Welcome page if you do not have scheduling 
privileges. 

Table 4.  Bulletin Types

Text Bulletin

Lets you create one or more single text block bulletins individually or as a group. You can 
choose any name you wish. This name does not appear anywhere on the bulletin but does 
appear in the playlists that play the bulletin; this name also appears in the My Content page. 
You can enter free-form text in this block. You can let the text wrap automatically or you can 
use the Enter key to form line-breaks. If Recommend Font Size is checked, the system will 
automatically calculate the font size and adjust it when you change the text or font. If not 
checked, you can control all aspects of the font: Bold; Italic; Underline; Strikethrough; Color.

Bulletin Type Description

Text Bulletin Lets you create one or more single text block bulletins individually or 
as a group. 

Text Bulletin with 
Title

Lets you create one or more dual text block bulletins individually or as 
a group. The first text block is treated as a title. 

Bulletin from 
Template

Lets you create a bulletin from an existing template. Templates must 
be created in advance by an administrator using VBrick Desktop. 

Media Bulletin Lets you create one or more still graphic or video bulletins individually 
or as a group. Supported file types are shown in Figure 6 on page 19. 

Graphic Link Lets you create a still graphic bulletin from a graphic file that is 
outside of Digital Signage and changes from time to time. 

Web Page Bulletin Purchase option. Lets you play a web page inside a bulletin. Displays as 
much of the web play as the content block will allow. 

Weather Bulletin Lets you create a new bulletin that displays weather information for a 
single location. The bulletin is auto refreshed by the Weather Adapter. 

Free Form Bulletin Lets you create non-standard bulletins with the Free Form Editor. The 
Free Form Editor is part of VBrick Desktop. 
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Creating a Text Bulletin 

The following procedure explains how to create a text bulletin. The basic steps described 
here are used for all bulletins. Once created, a bulletin (or a ticker) must be scheduled. 
Bulletins and tickers are scheduled to playlists and crawl lists respectively. If scheduled, they 
can be viewed/edited on the Now Playing page; if not scheduled, they can be viewed/edited 
on the My Content page or the My Tickers page. When creating a bulletin or a ticker, the 
content is saved as soon as you hit the Next button. If you subsequently Cancel out, without 
scheduling, the content is still saved for future use.

 To create a text bulletin:

1. Click on Create > Text Bulletin. 

Figure 6.  Create Bulletin Page

2. Enter a bulletin name.
3. Enter the bulletin text. 
4. Use the font manipulation tools on the right to modify the appearance of the text. To 

modify the font size you must uncheck Recommended Font Size. Any changes you make to 
the size, color, or font style apply to all of the text in the bulletin. 

If you are creating bulletins with imported TrueType fonts, these fonts must be installed 
on your PC, on the Content Manager, and on the Signage Player(s).

5. Optional. Select a background from the dropdown list. Click on the ... button on the 
right to see thumbnails of all available backgrounds.

6. Optional. Select an audio file from the dropdown list. 
7. Click Preview to see your changes. 
8. When done click Next to move to the Scheduling page.
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Figure 7.  Schedule Bulletin Page

9. Use the Scheduling page to associate your bulletin with a playlist and schedule when it 
will play. For more about this page, see Scheduling Content on page 22. If you click 
Cancel, the bulletin will be saved (in Manage > My Content) but will not be scheduled.

10. Select one or more playlists (using the Ctrl button on your keyboard) that this bulletin 
will be associated with. 

Optional. Check the Desktop Messenger box to play the content as a bulletin and as a 
desktop message. Click Skip Playlist to send the content only as a desktop message. See 
Desktop Messenger on page 39 for more information. 

11. Configure the remaining fields on this page as follows:

12. Click Finish when done to display the Welcome page. 
13. To view the bulletin, go to Now Playing > Playlists.

Note Use the Group button to create a bulletin that spans more than one page. Bulletins 
grouped in this way will play in the order specified. Bulletins in the content library are 
listed alphabetically. 

Title Read-only from previous screen. 

Show Schedule the days, dates, and times when this bulletin will be shown. Use any 
or all of the controls available. 

Display Choose from the available options. To add specific display periods, click 
Selected Periods > and if necessary Add More Display Periods. 

Pace Choose Automatic based on amount of text (recommended) or set manually 
(3–7 seconds is typical).



Create

VBrick Digital Signage Quick Start 15

Figure 8.  Manage Playlist Page

14. Select the Playlist that the bulletin is associated with and scroll to the bottom of the page. 
The new bulletin is added at the end of the playlist. The bulletin will play on the dates 
and times specified or you can click Edit Schedule to modify. 

Text Bulletin with Title

This is identical to a Text Bulletin but has an additional text block for a title. Lets you create 
one or more dual text block bulletins individually or as a group. The first text block is treated 
as a title, while the second text block is treated as the body of the bulletin. Each block is 
defined separately. Default = 4:3 aspect ratio.

Bulletin from Template 

Lets you create a bulletin from an existing template. Start by selecting a template. Templates 
must be created in advance by an administrator using the VBrick Desktop application. See 
Template Editor on page 48 more details. The options available on the template depend on 
what has been "locked" by an administrator. For example you may be able to change the text 
but not the background image or font size. 
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Media Bulletin 

Lets you create one or more still graphic or video bulletins individually or as a group. 
Supported file types are shown in Figure 6 on page 19. To upload an image or video greater 
than 20 MB see the Media Importer on page 54.

Graphic Link

Lets you create a still graphic bulletin from a graphic file that is outside of Digital Signage 
and changes from time to time. For example Digital Signage will automatically refresh a 
weather map image from the web based on an interval you specify. If you see black bars 
above and below the image, adjust the Aspect Ratio or use a specified background image as a 
matte. To get the URL of a web image, right-click on the image and select Properties. Then 
copy and paste the URL into the Link Path field in the application.

Web Page Bulletin

Purchase option. Lets you play a web page inside a bulletin. Displays as much of the web page 
as the content block will allow. Enter the complete URL to the web page you wish to display. 
The Test URL button verifies the URL; it does not guarantee the Signage Player can display 
the page correctly. As shown here, the application displays a default placeholder image; it 
does not display the actual web page.
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Weather Bulletin

Lets you create a new bulletin that displays weather information for a single location. The 
bulletin is automatically refreshed by the Weather Adapter every hour. The Weather adapter 
must be configured before you can create a Weather bulletin. See Configuring Adapters on 
page 33. 

Creating Tickers 
Various types of tickers (also known as "crawls") are available depending on what options you 
have installed. A text ticker is manually defined from text that you provide. Other types of 
tickers (e.g. a weather ticker) derive their information from an external source. The Weather, 
and News adapters must be configured in advance. See Configuring Adapters on page 33 
more about this. You cannot set the Speed, Background, and Font for individual tickers. 
These options are set for each crawl list on the Configure > Content Settings > Crawllists 
page. 

Table 5.  Ticker Types 

Note If your network includes a DNS server, each channel player must have a DNS entry 
(configured by a network administrator) or the web bulletin will not play.

Ticker Type Description 

Text Ticker Lets you create a single text ticker manually (from text you supply).

Weather Ticker Lets you create a ticker that displays weather information for a single 
location. The ticker is automatically refreshed by the Weather Plugin. 

News Ticker Purchase option. Lets you create a ticker that displays news headlines 
and briefs. The ticker is auto refreshed by the RSS Feed. 



18 © 2012 VBrick Systems, Inc.

Text Ticker 

This feature lets you create a single text ticker manually (from text you supply).

 To create a text ticker:

1. Click on Create > Ticker > Text Ticker. 
2. Type a message that will display in the ticker. 
3. Click Preview and you will see the text scroll across the page from right to left. 
4. Click Next to save and go to scheduling page to schedule the ticker to a crawl list (use the 

Ctrl key to schedule to multiple crawl lists)

Note: You cannot adjust the "pace" of individual tickers. To set the pace for all tickers, 
go to Configure > Content Settings > Crawllists to set the Speed, Background color, and 
Font for tickers. 

Weather Ticker 

This feature lets you create a new ticker that displays weather information for a single 
location. The ticker is automatically refreshed every hour by the Weather Adapter. You must 
configure the Weather Adapter before you can create a Weather ticker. Before you can create 
a weather ticker, the adapter must be configured. See Configure > Weather Adapter on 
page 34 for details.

 To create a weather ticker: 

1. Click on Create > Ticker > Weather Ticker.
2. Select a Location from the dropdown. 
3. Check the boxes to include or exclude weather options. 
4. Click Preview to view the configured ticker and edit as necessary. Then click Next. 
5. Select a crawl list, configure the schedule, and click Finished. If you click Cancel, the 

ticker will be saved in Manage > My Tickers but will not be scheduled. 

Adding Video 
The basic steps needed to add a streaming video window to your display device are listed 
below. For detailed, step-by-step instructions, see Adding a Video Stream on page 52. 

 To add a streaming video window to a Signage Player: 

1. Configure the Signage Player hardware for a Stream Window. Go to Configure > Channel 
Players > Hardware. 

2. Associate a layout (that has a video stream overlay) with the Signage Player. Go to 
Configure > Channel Players > Layouts. 

3. Add a Program URL that points to a video stream from an encoder. Go to Now playing > 
Streams.
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Managing Your Content

Adding Files to the Background Library 

Table 6.  Supported Media File Types

Working with Playlists

The bulletins shown in Figure 8 are on the Now Playing > Play Lists page. The bulletins are 
listed in linear order from the top down. This is the sequence in which they will play. Use the 
controls associated with each bulletin or with each bulletin group to modify, group, schedule, 
rearrange, etc. the bulletins.

 Graphics Files A graphics file in the background library (under Manage > 
Background Library) is added at a 4:3 aspect ratio. If you will be using 
the graphic in a 16:9 content block you will need to click the Create 
button and create a Widescreen image to use. 

Media Files You can add an audio, video, or graphic file to the corresponding 
library under Manage > Audio, Video, or Graphic Files. If you will be 
using Flash (.swf) files, Adobe Flash 8 or higher must be installed on 
the Signage Player.

Graphics jpg | tif | gif | png | bmp

Video asf | avi | mpeg | mpg | wmv | mp4 | m4v | mov

Audio mp3 | wav 

Playlist Choose a playlist from the dropdown. You can filter the list using the 
radio buttons on the right. 

Transition Select the transition that will be played in between bulletins in the 
playlist and click Change. This is the Default Transition. All bulletins in 
the playlist will use this default unless an individual bulletin has a 
different transition specified. 

Create Group To create a group of bulletins that will be played together, check the 
Select box next to each bulletin and click Create Group. A group has 
its own set of controls (Up, Down, Ungroup, etc.) that apply only to 
the group. If checked, all bulletins in the group will use the Same 
Schedule. 

Select Check to perform an action (for example move, edit, ungroup, etc.) on 
the selected bulletin.

Edit Bulletin Launches the particular tool (for example Create Media Bulletin) that 
was used to create the bulletin page so you can modify it as necessary. 

Up/Down Move the selected bulletin(s) up or down in the playlist or in the 
group.

Remove from 
Schedule

Remove the selected bulletin from the schedule for this playlist. 
Bulletins removed in this manner are deleted from the playlist but can 
still be found on the Manage > My Content. Note that bulletins in My 
Content are listed in alphabetical order.
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Managing Content

The Manage > My Content page is a content library or repository for all bulletins (in 
alphabetical order) existing within the application. Use this page to view bulletins and 
organize them into folders. See Managing Content on page 29 for more information. After 
creating a bulletin, if it is currently scheduled to play, it is viewable under Now Playing > 
Playlists. If not scheduled to play, it can be found under Manage > My Content. 

Figure 9.  Manage > My Content Page 

Edit Schedule Modify the schedule for this bulletin only. 

Note When creating a bulletin, the Next button automatically saves the bulletin in the My 
Content library and launches the "scheduling" page. To exit at that point (without 
creating a schedule) simply click Cancel. 

Folders For Organized by user. Shows the folders (if any) for the selected user. 

Create Folder 
Named

Create a new folder for the specified user.

folder_name Use controls to add, empty, or remove folders. Use Schedule All as a 
Group to create one schedule for all items in group. Click on 
folder_name to see more options. Note that you cannot delete 
scheduled bulletins: you must unschedule them before you can 
perform a delete. Use "delete" carefully. If you delete a bulletin from 
this page it cannot subsequently be retrieved. 

Bulletins for Shows all bulletins for the selected user. 

Delete All 
Unscheduled

Use with care. Permanently deletes all unscheduled bulletins for the 
specified user. 

Select Check one or more bulletins to move to a folder. 
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Importing Content 

The Import feature lets you import Images, Videos, or PowerPoint presentations as a group. 
If you are importing video or image files larger than 20 MB, you must use the standalone 
VBrick Desktop application (see Media Importer on page 54). 

Importing PowerPoint Presentations

This option lets you import PowerPoint .ppt/.pptx files directly to the Channel Player for 
playback in native mode. If you plan to import PowerPoint slide presentations, a registered 
copy of PowerPoint 2003, 2007 or 2010 must be installed on every Channel Player where the 
slides will be shown. You will also need to consider the PowerPoint Setup Guidelines 
explained below. If a Channel Player does not have PowerPoint installed, it will be skipped in 
the playlist. See Installing PowerPoint on a Channel Player on page 57 for PowerPoint 
installation instructions. 

Figure 10.  Import > PowerPoint

Edit Opens the tool that was used to create the bulletin.

Schedule Launches the scheduler page so you can set or modify a schedule. 

Upload PowerPoint File Browse your network or hard drive for the PowerPoint file you 
wish to upload. 

Name Your Presentation Give your file a name for use in Digital Signage. 

Choose an Aspect Ratio Choose the Aspect Ratio of the file you are importing. 
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PowerPoint Setup Guidelines 

• You will need to disable error notification on each Channel Player for PowerPoint to 
work properly. See Disabling Error Notification on page 58. 

• You cannot schedule the same PowerPoint file to play simultaneously on the same 
Channel Player.

• The time between slides is configured on the Schedule page. If you do not want all of the 
slides to play at the same time interval, they must be imported separately.

• Before upload, the PowerPoint presentations must be configured for non-human 
interaction. In order to play correctly without intervention, you must set up the slide 
show as follows: 
• PowerPoint slides are played as a presentation (slide show). On the Transitions tab, 

the Advance Slide option must be set with On Mouse Click checked and After (or 
Automatically After) unchecked. This lets the presentation play back automatically. 

• Custom animations are supported. On the Animations tab, the Start must be set to 
either With Previous or After Previous.

Scheduling Content 

The Schedule feature lets you schedule bulletins and tickers to playlists. You can schedule 
content for delivery at a specific time and date to relevant Signage Players. You can also 
schedule a bulletin or ticker to repeat on specific days of the week and for one or more time 
periods each day. This feature is called the "daypart interval." The maximum number of 
daypart intervals is 24. When scheduling to endpoints, your license(s), determines whether 
you can schedule content to Signage Players or Desktop Messengers. Depending upon the 
options available and the options you select, you can schedule to a Playlist or a Publisher. 
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Figure 11.  Schedule > My Content Page

You can choose to start showing the bulletin Today for a specific amount of time or you can 
choose a start and end date and time. You can also choose to have the bulletin play on a 
specific day or days within the chosen start and end date and time. Normally the start and 
stop dates and times are figured for each display, but if you check Override Local Time Zones 
then only the central Digital Signage server's time will be used. You can control the amount 
of time that each bulletin is displayed by letting the system calculate a pace based on the 
amount of text or by specifying a number of seconds. The calculated pace is based on the 
number of words per second specified in the owning Aspect Ratio (see Configure > Content 
Settings > Aspect Ratios).
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The Now Playing pages are primarily used to view and manage playlists and tickers that are 
currently playing. Use the Manage functionality to manage bulletins and tickers whether or 
not they are currently playing. 

Playlists
Review and manage playlists and playlist items (bulletins) whether or not they are currently in 
use. This page shows all of the bulletins scheduled to a specific playlist and has the following 
controls:

Tickers
Review and manage tickers and crawl lists whether or not they are currently in use. This page 
shows all of the tickers scheduled to a specific crawl list and has the following controls:

Streams
Displays the currently scheduled streams that play in a Stream Window and lets you add or 
delete streams. To configure a streaming option for live streaming from a VBrick encoder, see 

Select Bulletin Check box to create a group of bulletins.

Transition Select a transition for each slide. 

Edit Bulletin Returns to Create Bulletin page. 

Up | Down Moves bulletin up or down in playlist.

Remove Removes bulletin from playlist (deletes from schedule). 

Schedule Lets you reschedule the bulletin.

Edit Crawl Returns to Create Ticker page. 

Up | Down Moves ticker up or down in crawl list.

Remove Removes ticker from crawl list (deletes from schedule). 

Schedule Lets you view/edit the ticker schedule. 
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Configure > Channel Players > Hardware. Then be sure to use the Display Layout Editor to 
create a layout that includes the Stream Window. For more about adding streaming video see 
Adding a Video Stream on page 52. 

 To define a Live Stream:

1. Go to Now Playing > Streams and click Add Program.
2. Enter a Program URL for a live stream from a VBrick encoder (Table 7) or a stored 

stream from a VBrick VOD server (Table 8) in one of the supported URL formats. Use a 
URL format that matches the encoder or server type and the network configuration at 
your site. 

3. Create a schedule for the live stream.

Table 7.  Supported URLs – Live Streams 

Encoder Type Program URL Format Description

Windows Media mms://<encoderIP>/
vbrickvideo1

Multimedia Messaging. Must match 
Resource Name on Encoder > Server 
page in IWS.

H.264 (Multicast) vbhttp://<encoderIP>/
vbStream1.sdp

RTP invoked from .sdp. Must match .sdp 
file name on Program Configuration > 
Transmitters page in VBAdmin. 

vbricksys://
ip=<multicastIP>&port=<port>&
ssmsourceip=<source_IP> 

Transport Stream. Must match Destination 
and Destination Port on Program 
Configuration > Transmitters page in 
VBAdmin.

H.264 (Unicast) vbrtsp://<encoderIP>/
vbStream1S1

RTP. Must match Stream URL on Program 
Configuration > Servers page in VBAdmin. 

vbrtsp2://<encoderIP>/
vbStream1S1 

Transport Stream. Must match Stream 
URL on Program Configuration > Servers 
page in VBAdmin. 
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Table 8.  Supported URLs – Stored Streams 

Publishers
If your site is licensed (and configured) for Desktop Messenger, bulletins will be sent to those 
on the Desktop Messenger distribution lists. See Configure > Desktop Messenger on 
page 39. 

Player Snapshots
The Channel Player Snapshots screen (accessible by going to Now Playing > Player 
Snapshots) provides a list of all signage players currently added to the system and provides a 
"snapshot" of what each player is currently playing. This feature is a convenience for 
developers.  You can configure how often (minimum = 15 sec) snapshots are taken on the 
Configure > Content Settings > Channel Player Snapshots page. Use the radio buttons to sort 
by Device Name, DNS Name/Address, etc. A thumbnail placeholder is displayed when you 
initially open the page. Select a Signage Player and click Refresh to update the image. 

Figure 12.  Signage Player Snapshots Page 

Server Type Program URL Format

VOD-WM (Windows Media) http://<vodIP>/<pub_point_name>/<content.wmv>

VOD-W (MPEG-1/2, H.264) http://<vodIP>/<content.mpg>

VOD-D (Darwin) http://<vodIP>/<content.mp4>

Note Video Snapshots are not supported by Windows XP with hardware acceleration 
turned on and may not appear in your snapshot. To turn hardware acceleration on or 
off go to Start > Control Panel > Display > Troubleshoot. 
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Chapter 4
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The Manage pages have library tools that are primarily used to view and manage approvals, 
bulletins, tickers, and media files present in the content library. This content is used to create 
bulletins, tickers, and playlists. All content resides here regardless of whether it is scheduled 
to play or not scheduled to play. This is the main content repository: if you delete a bulletin 
from the Now Playing pages for example, the content is still saved in the content library; if you 
delete content from the library, it is gone forever. 

Managing Content 
The options you see on the Manage pages depend on your privileges as established by the 
system administrator.

Approval Used to approve bulletins, tickers, and streams. If you are an administrator 
or content approver you may need to approve bulletins, tickers, and 
streams submitted by other users. All of the bulletins and tickers that 
require approval are displayed on the Manage > Approval pages. 
If e-mail has been configured for Digital Signage (see Configure > 
Content Settings > SMTP Settings) you will be notified, as an 
administrator, of all bulletins and tickers that have been submitted that 
require your approval. Whenever you login to the system, the welcome 
page displays the number of bulletins and crawls that require your 
approval on each playlist and crawllist.
To approve a bulletin for example, go to Manage > Approvals > Play Lists 
and display the unapproved bulletins in the playlist. Once you check the 
Approve box, the bulletin is added to the playlist schedule. The same steps 
are used to approve tickers and streams. These items can be added to the 
calendar but will not play until they are approved (or unless the user 
scheduling these items is assigned the role of Administrator or Content 
Approver). Note that only authorized administrators and content approvers will 
see the Approve option in the navigation tree. 

My Content The Manage > My Content page helps you manage all of the bulletins you 
(and others) create. The screen is divided into two main sections: Folders 
and Bulletins. Folders in the folders section group bulletins. The bulletins 
section shows bulletins that are not grouped into folders.

My Templates This is the library of templates. The Manage > My Templates page helps 
you manage all of the templates you (and others) create. This function lets 
a user with appropriate privileges create a bulletin from a template or 
delete a template. Note that you create templates using the Template Editor 
in VBrick Desktop. 
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My Tickers This is the library of tickers. The Manage > My Tickers page helps you 
manage all of the text, weather, and news tickers that you (and others) 
create. The information is organized by user; anything not included in a 
folder is displayed in the list.

Events This function lets you manually create daily, weekly, or longer-term event 
schedules. 
• Daily Events – lets you review, add, remove or change events for the 

Event Schedule Plugin. this screen gives you access to all the events the 
plugin polls when filtering events to create bulletins.

• Rooms – lets you add or remove rooms available for Events.
• Types – lets you add or remove types available for Events.
• Statuses – lets you add or remove types available for Events.

Graphic Files Lets you to manage the still graphics available for use as bulletins on the 
Create Media Bulletin screen. Files greater than 20 MB should be uploaded 
using the Media Importer. Graphic files are stored in the Graphic Files 
library. Click on the link to open the Upload Still Image page which lets 
you upload ten image files at once. You must specify a  name/description 
for each file that you upload. This name/description is used when creating 
or modifying bulletins. Digital Signage supports the following image types: 
.jpg, .tif, .gif, .png, .wmv, .bmp.

Video Files Lets you manage the video files available for use in bulletins. Click on the 
link provided to upload video clips. You can upload up to ten video clip 
files at once as long as the total file size does not exceed 20 MB (use the 
Media Importer tool to upload files greater than 20 MB).You must specify 
a name/description for each file that you upload. This name/description is 
used when creating or modifying bulletins. Digital Signage supports the 
following video file formats: .asf, .avi, .mpeg, .mpg, .wmv, .mp4, .mov. 
Note: Anytime the frame rate of a Flash movie (.swf) exceeds 12 frames 
per second, the frame rate will be displayed. In order to work with other 
animations and videos playing at the same time on Signage Players, VBrick 
recommends that Flash movies not exceed 12 frames per second. 

Audio Files Lets you manage the audio files available for use in bulletins and as 
background audio on signage players. Digital Signage does not contain any 
pre-loaded audio files. This screen will not contain any files or options for 
managing files until you have uploaded audio files to the library. Click on 
the link provided to upload audio clips. You can upload up to ten audio 
clip files at once as long as the total file size does not exceed 20 MB (use 
the Media Importer tool to upload files greater than 20 MB). Digital 
Signage supports .mp3 and .wav audio files. 



Manage

VBrick Digital Signage Quick Start 31

Background 
Library

Lets you manage the backgrounds available for use in the entire system. 
These files are used with all bulletins (text, free form, news, weather, event 
schedules, etc.) and as background images on Signage Players when using 
backgrounds in content block layout schemes. Click on the link provided 
to upload up to five background files of up to 20 MB at once. These files 
are added to the library. You can also upload backgrounds using the Media 
Importer as long as the total file size does not exceed 1.99 GB. 
If a background image is being used it cannot be deleted. See Configure > 
Content Settings > Text and Template Settings to change the default 
background image. Note that once you have uploaded a graphic file in its 
primary aspect ratio, you can click Create to save it in other aspect ratios. 
See Configure > Content Settings > Aspect Ratios to add or change aspect 
ratios. 
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Chapter 5
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Configuring Adapters 
Many of the Digital Signage tools have specialized adapters that must be configured in 
advance. A good example is the Weather Adapter: before you can create a Weather bulletin, 
you must configure the Weather adapter with your geographic location and other data.

Mass Alert Notification

EMS Data Adapter

Mass Alert Notification Purchase option. The ability to quickly mass communicate to 
groups of individuals in the case of an emergency is critical for 
higher education and businesses throughout the world. Digital 
Signage has the ability to respond to mass alert notification 
conditions by halting all normal operations and focusing all 
system resources exclusively on the processing and distribution of 
mass alert content to all signage players that are part of the 
installation. The Mass Alert Notification will continue until an 
intentional action is taken to stop it. To configure a Mass Alert, 
see Configuring a Mass Alert Notification on page 80. 

 To launch a mass alert:

1. Click the Activate Mass Alert Notification button near the top 
of the Welcome page.  

2. Select an Alert Type.
3. Then enter event-specific Alert Text and click Enable Mass 

Alert. The mass alert will halt all normal operations and display 
the emergency alert until you click Disable Mass Alert.

EMS Data Adapter Purchase option. VBrick's Digital Signage supports the integration of 
event data from Dean Evans & Associates, Inc. EMS® software. 
Before you can create bulletins that display events from the Dean 
Evans EMS software you must first configure the Dean Evans EMS 
Adapter. Once you have configured and tested the Dean Evans EMS 
Adapter you can create bulletins that contain the Dean Evans EMS 
events. For more information see EMS Data Adapter on page 69.



34 © 2012 VBrick Systems, Inc.

News Adapter

Weather Adapter

Before you can create a weather bulletin or a weather ticker, you will need to configure the 
Weather Adapter. This adapter is a free service that uses the National Weather Service. 

News         Configure the news adapter to retrieve and display content of your 
choice via the web. This feature lets you point to a repository URL 
which provides several categories of news data for a bulletin or ticker. 
This feature also enables RSS capabilities Once configured, each RSS 
feed becomes and individual news category. These categories, along 
with categories from the VBrick News Service, will be available for 
bulletins and tickers.
• VBrick News Service – Requires a subscription-based UPI news 

feed. This provides a link to a VBrick server that provides brief 
news stories from UPI. Used for news bulletins or tickers. 

• RSS Feeds – used for news bulletins or tickers. This is an RSS 
adapter that lets you to pull in news stories from an RSS feed. 
Enter a valid RSS URL and specify an update interval.

Current Conditions Lets you review, add or change current weather conditions for a 
Weather Location. This screen gives you access to all the current 
conditions the Weather plugin polls when generating bulletins and 
crawls.

Forecast Conditions Lets you review, add or change forecast weather for a Weather 
Location. This screen gives you access to all the forecasts the Weather 
plugin polls when generating bulletins and crawls.

Locations Lets you review, add or delete Weather Locations. Weather Locations 
are central to tracking current and forecast weather conditions. 
Bulletins and crawls maintained by the Weather plugin generate based 
on the Weather Location selected.

Icons Lets you select Weather Icons for summary weather conditions. Each 
summary weather condition can be depicted graphically on a bulletin. 
The system comes with standard graphics for each summary, but you 
are free to use your own graphics.

Zones Lets you review, add, change or delete Weather Service Zones. 
Weather Service Zones are central to pulling current and forecast 
weather conditions down from the National Weather Service FTP 
site. The NWS (National Weather Service) defines zones to represent 
geographical areas within states. The system comes preloaded with all 
zones known at the time of install.

Location Zone Map Lets you map Weather Locations to Weather Service Zones. The 
purpose of this mapping it to tell the National Weather Service 
adapter which weather locations you want to update automatically. 
The NWS Adapter will only try to find current and forecast weather 
conditions for zones mapped in this screen.
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Security

Digital Signage security measures include the options listed below. To set passwords, go to 
System Tools > Change Password.

Content Settings 

The Configure Content Settings screen allows you to configure the major content creation 
attributes of the Content Server, along with the behavior of major services and plugins. 

Download Now Tests the National Weather Service zone mapped to a Weather 
Location. You can see what information, if any, Digital Signage is able 
to extract from the weather service. Use this screen to verify that the 
automatic weather update is going to work for a Weather Location.

Security Policy Lets you set the security parameters for the Digital Signage 
installation. The security policy covers password rules, intrusion rules 
and new account rules. All changes on this screen take effect 
immediately. Changes to password rules may require you to adjust 
your password immediately to comply with the new rules. When a user 
logs in their password is checked against the existing password rules 
and forced to change their password if it no longer meets the valid 
password criteria.

Intrusion Policy Lets you view all users that have been locked out of the system and to 
manually clear the lock-out.

Users Helps you manage users that are allowed access to the Digital Signage 
system. In order to view this screen you must be an administrator with 
the correct privileges. This screen lets you add, change and remove 
users completely from the system. Before adding new users to Digital 
Signage, you should first consider the role the user will fulfill. You may 
need to create new roles or adjust existing roles in the system on the 
Configure > Security > Roles page. Once you've decided what role(s) 
the user will play and what playlists and crawllists they can access, you 
can add them to the system. 

Roles Helps you manage roles that group privileges within the system. Roles 
are normally named for the function the user performs, such as 
Content Administrator or Bulletin Creator. If you have a lot of users 
you can create as many specific roles as you wish then assign as many 
roles as needed to each user. Alternately you can create a small 
number of roles; it depends upon your organization and its 
requirements. This screen lets you add, change and remove roles from 
the system.

Playlists Lets you configure (or rename) the play lists that users may choose 
from when scheduling bulletins. A play list is assigned to one or more 
Signage Players for rendering on a display device. You can only add 
new play lists if your current licensing supports it.

Playlist Groups Enterprise only. Lets you organize your playlists into groups. The 
scheduling page will subsequently let you select playlists by group 
name.
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Crawllists Lets you configure (or rename) the tickers (also called crawl lists) that 
users may choose from when scheduling tickers. A ticker is assigned to 
one or more Signage Players for rendering on a display device. You 
can only add new tickers if your current licensing supports it. This 
setting also lets you modify the speed, background, and font used by each 
ticker.

Crawllist Groups Enterprise only. Lets you organize your crawllists into groups. The 
scheduling page will subsequently let you select crawllists by group 
name.

Playback Tracking Lets you record playback times for tracking and reports.

Text and Template 
Settings

Lets you change the default background images for the text bulletin 
templates. These templates define the initial appearance of bulletins 
you create in Text Bulletins and Text Bulletins with Title.

Aspect Ratios Lets you configure the aspect ratios that users may choose from when 
configuring Signage Players, Play Lists and certain bulletin types. An 
aspect ratio is the ratio of width to height. Digital Signage uses this 
information when applied to a bulletin to properly draw the bulletin 
on different devices. 

Play Modes Lets you define the play modes available for all Signage Players. A play 
mode is a mode of operation for a player. It currently includes visual 
settings, such as content blocks, and in the future will include behavior 
settings, such as maintenance operations for plasma displays. 
Configuring play modes is done on a per Signage Player basis. You can 
only add new play modes if your current licensing supports it.

Web Title Lets you pick the name displayed to users when they access the Digital 
Signage URL for the Public Web Page feature. If you have multiple 
installations of Digital Signage this is helpful to distinguish them.

Boot Schedule Lets you specify the regular boot day and time. To keep the 
application and the operating system running smoothly Digital 
Signage automatically boots all devices once per week. This function 
lets you to set or change the default boot day and time. You can also 
use Boot Now to reboot the entire system (all devices) immediately. 
The auto reboot can also be disabled entirely. To manually disable auto 
reboot (not recommended) on the Content Server:

1.  Go to Start > Programs > Administrative Tools > Services. 
2.  Right-click on VBrick Boot Service and select Properties. 
3.  On the General tab, click Startup type and set to Disabled. 

Note: A reboot is not typically required after making configuration 
changes with the user interface. However if you notice that changes 
are not being applied, a reboot is recommended, keeping in mind that 
a reboot will impact any other applications running on the same 
machine. 

SMTP Settings Lets you define the SMTP server that should be used by Digital 
Signage when generating e-mail messages to Digital Signage users.
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Channel Players 

These settings apply to the Signage Player(s) present in your system. See Configuring the 
Channel Player on page 55 for additional details. 

E-Mail Plugin Lets you configure the Digital Signage E-Mail Plugin, a service that 
accepts e-mail messages from Digital Signage users and generates 
bulletins from the messages automatically. This feature requires a 
license but is standard on all versions. 

Event Management 
Plugin 

Lets you configure the Digital Signage Event Schedule Plugin, a 
service that generates bulletins automatically based on settings 
established by the Create Event Schedule Bulletin screen. The service 
regenerates all bulletins automatically so that all events displayed in 
the bulletins are relevant based on the time of day.

Channel Player 
Snapshots

Lets you configure a "snapshot" of what is being displayed on a 
signage player. The default Fetch Rate (how often the system will 
automatically take another snapshot) is 60 minutes. The minimum 
Fetch Rate is 15 minutes. For more information see Player Snapshots 
on page 27. 

Important Note The term "signage player" refers to the standalone devices that feed audio 
and video signals to LCDs, plasma displays, and other player devices. The terms "signage 
player" and "channel player" are used synonymously. We are transitioning to new 
terminology and there may still be legacy references to "channel player" in the application 
and in the online help.

Hardware Lets you add, change and remove signage player hardware from the 
installation. It also lets you refresh content, reboot and shutdown 
individual or multiple Signage Players. This page lets you register a 
player with the Content Manager server. This registration is necessary 
so that the Content Manager knows the dimensions of the player's 
viewing area and can send it content. You can only add a Signage 
Player that already has Digital Signage software installed. When done, 
the new player will be available for configuration on the Configure > 
Channel Players page.
• Network (DNS) Name or IP address – the name or IP address of 

the Signage Player you wish to add. DNS names, rather than IP 
addresses, are preferable. 

• Telnet Port – the port on which the player listens for remote 
commands. Default = 6500. 
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Hardware Groups Enterprise only. This page lets you group multiple signage players 
together in order to apply actions to the entire group. You can define 
as many groups as necessary but each Signage Player can only be a 
member of one group. 
• Maintenance – Lets you group multiple channel players for the 

purpose of taking actions across the entire group (such as Reboot 
and Mass Alert Notification). You can define as many groups as 
needed. 

• Play Mode – Use to change a group mode from Normal to the 
standard Alert by choosing the appropriate Mode and clicking 
Activate. 

• Alert Notification – Use to change a group mode from Normal 
Operation (which include both Normal and standard Alert modes) 
to a Mass Alert Mode. 

Layouts Provides a way to view, apply and schedule layouts that are defined for 
signage players. Every signage player has at least one layout defined 
for each Play Mode. The options available on the screen are based on 
the configuration of the web server. Layouts are created using the 
Display Layout Editor.
Note: Layouts are saved on the Content Manager and associated with 
a dedicated Signage Player—they are not saved on the Signage Player. 
If you move the Signage Player to a different network address, the 
layouts are lost and must be regenerated as explained below.
• Generate Stock Layouts – You can generate the stock layouts that 

are shipped with Digital Signage to a Signage Player at any time. 
This is useful if you add a player and then designate a video stream 
window. You can regenerate the stock layouts to get the layouts 
that include the video stream window. 

• Schedule – You can schedule a layout to play at certain times as 
long as the layout is associated with the Normal play mode. All 
other modes only support one layout so scheduling is not an 
option. 

• Apply to Player – You can apply a layout to a player immediately as 
long as the layout is associated with the Normal play mode. All 
other modes only support one layout and are always applied to the 
player. 

Layout Schedule Shows all the layouts scheduled on both the default and override 
timelines on the signage players. The override timeline is shown above 
the default timeline since the override takes higher precedence. You 
can use this screen to remove or edit the schedules. You cannot create 
layouts with this page. To create layouts, you must use the Display 
Layout Editor in the VBrick Desktop application. 
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Desktop Messenger 

The Configure Desktop Messenger screen allows you to configure the Desktop Messenger 
Distribution Lists and Publishers. If you are not using a separate publisher, enter the DNS of 
the Content Manager as the publisher with the default port of 28501. Desktop Messenger 
clients must be licensed in your system in order to access this screen. The Desktop 
Messenger is installed on a client PC and has a separate installer. Use the following steps to 
install Desktop Messenger. 

Server Configuration 

 To configure Desktop Messenger on the Content Server: 

1. On the Content Manager server, go to:

C:\Program Files\VBrick\Digital Signage\Content Services\Tei.Settigns.xml 

2. Edit Tei.Settings.xml as follows using Notepad or a similar editor. 
a. In the DesktopMessageDistriputor section, change the run value to true. 

<DesktopMessageDistributor 

run="true" 
runDelay="120"
networkChunkSizeInKb="100" />

b. In the DesktopMessagePublisher section, change the run value to true. 
<DesktopMessagePublisher 

run="true” 
runDelay="60"
networkChunkSizeInKb="100"
listenerPort="28501"
contentKey="00000000-0000-0000-0000-000000000000" /> 

c. Replace the contentKey value in the previous step with your actual license key. To get 
your license key, cut and paste the value in key.txt from the following folder: 

C:\Program Files\VBrick\Digital Signage\Content Services\License\key.txt 

Client Installation

 To install Desktop Messenger:

1. Launch the Digital Signage application from a PC and log in.
2. Go to System Tools > Install Desktop Messenger. 

Group Mode Enterprise only. Lets you activate a specific mode on a set of players at 
once rather than one player at a time.  Every installation has a built-in 
group called “All Players” that can be used to activate a play mode on 
all players at once. In order to activate only some players, you will 
need to create groups by using the Configure > Channel Players > 
Groups screen.  This page does not show the currently activated mode 
on every group since the players within the group can have different 
active modes at the same time. 

Note The number of Desktop Messenger users is limited to the number of purchased 
licenses. If this number is exceeded, the application will install but will not run. To get 
more licenses contact VBrick Support Services. 
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3. Click on the Desktop Messenger link and follow the prompts. When done, a Desktop 
Messenger icon will be displayed on the toolbar. 

4. Right-click on the Desktop Messenger icon and select Configure.

5. In the Publisher URL field, enter the URL or your Content Manager server in the 
following format and click Test.

<content_manager_ip_address>/DesktopPublisher/DesktopGateway.asmx 

If you can successfully connect to the server, continue to the next step. If you cannot 
connect, most likely the URL is wrong or you do not have the required licenses. 

6. Click the Add/Change button, select Everyone, and click Subscribe. 
7. Press OK in next dialog box and a minimized player (with the default message) will be 

displayed in the lower right corner of the desktop just above the system tray. 

8. Use the various control on the player to minimize, expand, page through previous 
messages, etc.

Using Desktop Messenger

A Desktop Message is a bulletin that excludes video sections. If an installation is licensed for 
Desktop Messenger and the user has the "Create Desktop Message" privilege, the schedule 
screen includes a check box for Desktop Messenger. You can schedule the bulletin to both 
Playlists and the Desktop Messenger, or you can use Skip Playlists to schedule exclusively to 
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the Desktop Messenger. The Desktop Messenger distributes messages to all of the 
configured Desktop Publishers. 

Once the bulletin has been published to the Play List(s), or the play lists have been skipped, 
the publish schedule screen is displayed. The schedule attributes are different than for 
Playlists. A message can be scheduled for one-time publishing or for recurring publishing. 
There is no concept of a list of items that play over and over. Also, scheduling is not realtime; it 
may take several minutes from the time that a message becomes eligible for publishing until the time it 
is actually delivered. The Now Playing > Publishers page is similar to Now Playing > Play Lists. 
It gives you the opportunity to change or remove the message from the schedule or to edit 
the bulletin associated with the desktop message. When a desktop message is sent to a 
configured client, the message window automatically pops up to display the message. 

Public Web Page

This feature lets you view playlists in a web browser. It provides a way to view playlist content 
generated by Digital Signage for those people who do not have digital signage accounts. It 
can also be used to embed the slide show in organizational web sites and portals. The play 
lists must be marked as "public" in their setup. The screen comes with standard navigation 
controls for Play, Stop, Next, Back, First and Last. (To set the web page title, see Web Title on 
page 36.) The following table explains how to make a public image clickable (for navigation 
to another web resource) and the format of the URL. In order to provide navigation from a 
public image to another web resource, the title of the bulletin must be formatted as a valid 
URL. This title can be in the form http: or https: The URL format is: 

http://host/public/playlistview.aspx?option=value&option=value ... 

The following example shows a typical URL with all options set to "on." 

http://demo2.vbrick.com/public/playlistview.aspx?playlistNbr=1&mode=Normal&height= 
480&installationLabel=large&banner=100&navigation=100 

Option Required Description

playlistNbr Yes This option is required and is numeric. It represents 
the play list number. 

mode Yes This option is required and is alphanumeric. It 
represents the play mode of the play list. 

height Yes This option is required and is numeric. It represents 
the height in pixels of the slide show image (this does 
not include the title banner or navigation buttons). 
The aspect ratio of the image is preserved in all cases. 

installationLabel No This option is not required and if specified, must be a 
discreet value. It represents the relative font size of 
the title in the banner. The choices are:

xx-small 
x-small 
small 

smaller 
medium
large 

larger 
x-large 
xx-large
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Banner No This option is not required and if specified, must be 
numeric and between 0 and 100 inclusively. It 
represents the percent of the banner's configured 
height to use. 0 hides the banner and 100 shows the 
banner at full height. When not specified, the default 
value of 100 is assumed. 

navigation No This option is not required and if specified, must be 
numeric and between 0 and 100 inclusively. It 
represents the percent of the navigation button's 
configured height to use. 0 hides the navigation 
buttons and 100 shows them at full height (and 
width). When not specified, the default value of 100 is 
assumed. 

Option Required Description
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Admin Tasks 
The tasks described below are typically performed by a system administrator although they 
can be done by any user with the appropriate privileges. 

Change Password Lets you change your password and, if you're an administrator, 
reset the password for another Digital Signage user. 

Change Mode Lets you change the current Play Mode of any Digital Signage 
Display Server within the installation. You must have the required 
privilege to use this screen.

Install VBrick Desktop To use the VBrick Desktop on a PC you must install it. The 
process, at a high level, is to download the setup program, run it 
then configure the VBrick Desktop. Most of the steps occur on 
your PC, but the first step is initiated from the Web browser.

Install Desktop 
Messenger 

To use the VBrick Desktop Messenger on a PC you must install it. 
The process, at a high level, is to download the setup program, 
run it then configure the Desktop Messenger. Most of the steps 
occur on your PC, but the first step is initiated from the Web 
browser.

Active Alarms Shows you all active alarms on all Digital Signage devices (as long 
as the devices can communicate to the Content Server). Each 
alarm condition allows for restarting of services, rebooting of a 
device, e-mail notification, and/or auto clearing of alarms, as 
applicable. Some alarm conditions cannot be immediately 
communicated because they are indicative of a serious device or 
network problem.

Status Reports Shows you the status of all devices within the Digital Signage 
installation. The key to this screen is that every device reports its 
status every few minutes. If something is wrong with a device or a 
service on a device you'll see it not reporting in as OK. Click the 
button to send the status report to VBrick Support. 
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Error Logs Shows you the errors reported by all devices within the Digital 
Signage installation. The information is refreshed every few 
minutes from all devices in the network. This screen definitively 
records all internal application errors and many logical errors that 
can occur while running the system. If you ever need assistance 
with a problem, chances are its cause is documented in this 
screen. Click the button to send the error log to VBrick Support. 
Use the "System Configuration Report" link on this page to view 
license information and other data.
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Overview
VBrick Desktop consists of four bundled applications that will help you design bulletins, 
templates, and layouts. The VBrick Desktop installer must be downloaded from the link 
under System Tools > Install Digital Signage in the web interface. Note that once installed, 
only Digital Signage administrators have access to all VBrick Desktop features. The features a 
given user can access will depend on their assigned role (group of privileges). For more 
information, see Configure > Security on page 35. VBrick Desktop includes the following 
tools:

• Free Form Editor – used to create bulletins. 
• Template Editor – lets you create a bulletin with set fields for text or other media. 
• Display Layout Editor – used to create or edit "layouts" for a Signage Player. 
• Media Importer – used to import multiple media files a single batch. 

The first time Digital Signage is launched, you will need to enter the web address of the 
Content Manager. This is typically the name or IP address. Contact your network 
administrator if you need help.  If you are using a proxy server to connect to the Content 
Manager, check the box and you will see an Edit Proxy Settings button. When clicked, you 
can enter and save the proxy server settings. Enter your Digital Signage user name and 
password when prompted. These user credentials only need to be entered once: Digital 
Signage will remember them at the next launch. If the server name or IP address ever 
changes, click on the Connect to Digital Signage button to enter the new server and/or 
credential information. 

Installing the Desktop Tools 
VBrick Desktop consists of tools that will help you design bulletins, templates, and layouts. It 
also has a Media Importer tool for files (images and video) greater than 20 MB. The Desktop 
is typically installed on a user PC by running the installer. 

 To install VBrick Desktop: 

1. Launch the Digital Signage application from a PC and log in.
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2. Go to System Tools > Install VBrick Desktop. 
3. Click on the VBrick Desktop link and follow the prompts.
4. Once the application is installed, you run it from the Start menu. Go to Start > All 

Programs > VBrick > VBrick Desktop. 
5. When VBrick Desktop opens, go to File > Connect to VBrick and enter the Web Address 

of the Content Manager. Some sample addresses include: 

http://172.29.1.50/digitalsignage 
http://caber.vb.loc/digitalsignage 

Note VBrick Desktop runs on Windows desktops only; it does not run on Linux or 
Macintosh computers. It also requires a connection to the Content Manager. If the 
Content Manager is not running (or you lose your connection), the desktop 
application will return a "page not found" error when launched. 
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Free Form Editor
This tool is freeform editor used to create bulletins. The Free Form Editor lets you create 
new bulletins using any combination of text and compatible graphic files. You can also create 
new bulletins from existing bulletins and rearrange the contents of the bulletin by dragging 
the elements with the mouse. The user's role determines whether or not they can access this 
tool. 

Figure 13.  Free Form Editor



48 © 2012 VBrick Systems, Inc.

Template Editor
The template editor makes it easy to create bulletin templates with a preconfigured 
look-and-feel. It lets you create a bulletin with set fields for text or media insertion. It also 
allows for the ability to "lock" portions of the bulletin that cannot be changed nor accessed 
by the user. The sections for naming the Template, choosing the background, choosing an 
audio background file and aspect ratio are the same as in the Free Form Editor. Before you 
begin you will need to determine what items should be locked and made inaccessible and 
what sections (Text/Images) cannot be changed by user and can therefore be locked. The 
Lock Property section is assessable once you select the Create Template or Edit Existing 
Template button. When a property is checked, a Digital Signage user with the ability to create 
bulletins from a template will not be able to alter that property. 

Figure 14.  Template Editor
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Display Layout Editor
This tool is used to create or edit "layouts" that are associated with a Signage Player. Each 
Signage Player is configured with a default layout on the Configure > Channel Players > 
Layouts page. This page provides a way to create, view, apply and schedule layouts that are 
defined for Signage Players. Every Signage Player has at least one layout defined for each play 
Mode. The options available on the screen are based on the configuration of the web server. 
The actions you can take with the selected layout vary based on the type of layout and the 
web server configuration. For detailed information and a description of each field, see the 
"Display Layout Editor" topic in the online help.

Figure 15.  Display Layout Editor 

Note The layouts you create with this tool are saved on the Content Manager and associated 
with a dedicated Signage Player—they are not saved on the Signage Player. If you 
delete the Signage Player, the layouts are lost and must be regenerated. Use the 
Generate Stock Layouts button on the Configure > Channel Players > Layouts page to 
add stock layouts to a new Signage Player. 

Channel Player Select a Signage Player from the list.

Layout Select a layout. "Normal" mode supports multiple layouts, while all 
other modes are limited to one layout each. 

Name You can change the display name of the layout using the supplied 
dialog. 
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 To create a new layout:

1. Select a Signage Player. 
2. Select Create and enter a layout name when prompted. 
3. Select Edit. 
4. Select Name to edit a layout name. 
5. Select Display Resolution to choose or enter a resolution. 

Aspect Ratio You can choose the aspect ratio. Note that changing the aspect ratio 
does not change the physical dimensions of the layout. 

Display Resolution You can quickly change the dimensions of the layout with one of 
three options: 
• Match the current display resolution. 
• Select from the dropdown list of popular/common resolutions. 
• Enter a resolution manually. 

Content Blocks Each defined content block is represented in this list. Each block's 
placement is shown in pixels.
• P blocks – are playlists. 
• T blocks – are tickers. 
• VFO – denotes video feed overlays. 
• VSO – denotes video stream overlays. 
• DTO – denotes date time overlays. 

Preview The preview thumbnail demarks the content blocks using the same 
designations as the Content Blocks section, so you can easily match 
details to the visual representation. 
Note: All overlay windows are drawn half-transparent in the preview 
so that you can see if a regular content block lies below them. You 
can view at full size by clicking the image. 

Wallpaper You can select wallpaper from the dropdown menu or via the 
wallpaper browser. You can also opt not to choose a wallpaper. The 
Aspect Ratio is displayed before the wallpaper name in the list. You 
are free to choose wallpaper with any aspect ratio because wallpaper 
is always stretched across the entire layout surface. 

Background Audio You can select no background audio or a named audio. When you 
select an audio for the layout a speaker appears in the bottom-right 
corner of the layout's preview. 

Transitions Enabled If necessary you can disable transitions for the layout. This is useful 
for constrained player hardware. 

Placement You can adjust the placement of a block or overlay manually or you 
can type in the coordinates and click Apply. 

Playlist Content blocks can either be for playlists or tickers. The list of 
available playlists is limited to the playlists on the same play mode as 
the layout. 

Ticker Content blocks can either be for playlists or tickers. The list of 
available tickers is limited to the tickers on the same play mode as the 
layout. 
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6. Choose or type in a display resolution. 
7. Choose a wallpaper (optional). 
8. Choose a background audio (optional). 
9. Using the "+" tool, add types of blocks and/or overlays. 
10. Under Selected Block or Overlay Details you can manually enter the x, y, w, h coordinates 

and change the playlist, ticker, and video to be associated with each block. The 
coordinates 0,0 will make the content block flush to top left of layout. 

11. Change the floating date and time font attributes, format and alignment. 
12. Click Save or Delete Layout as necessary. 

 To edit an existing layout:

1. Select a Signage Player.
2. Select a layout from the dropdown.

Adding Content Blocks and Overlays

When you start editing a layout the tool assumes you want to add a new content block or 
overlay. A minimum of one content block with a playlist is required. If there are any existing 
overlays present in the layout, there will an Add button, a Select Top button and a Select 
Bottom button. When overlays are present all content blocks are on the lower layer (behind) 
and all overlays are in the upper layer (front). When no overlays are present there will be an 
Add button and a simple Select button. 

When you are in select mode and mouseover the existing content blocks and overlays, their  
boundaries glow to indicate you can select them. Once a content block or overlay is selected, 
sizing handles appear. You can click and drag the block around and resize it. A speaker will be 
displayed in the lower-right corner when audio is associated with the layout. Overlays can be 
positioned directly over content blocks. The overlays are depicted semi-transparently so you 
can see the content blocks underlying them. 

To add a content block, click on the  icon in the Content Blocks or Overlays area, and then 
click on the layout preview to display the dialog shown in Figure 16. Blocks cannot overlap 
one another but an overlay can overlap a block.  Your choices are constrained by licensing 
and by what is already present in the layout. It is typically easier to add the block or overlay in 
approximately the correct location then fine tune it with the mouse or edit the coordinates 
manually. Use the Delete Block button to remove the selected block from the layout. 

Getting the Best Video Quality

When adding a Video Stream Overlay (VSO) content block for a stream, be aware that the 
video quality is directly related to the resources on the host machine, the size of the video 
window, and the complexity of the layout (number of playlists and tickers). For best results, 
start with the "Best Quality" template for the encoder, then add an overlay window, tickers, 
and playlists as necessary. If there is a noticeable impact on the video quality, you can use any 
combination of the following steps: (1) use a different (lower quality) template, (2) reduce the 
size of the window, (3) limit the number of playlists and tickers. As a benchmark rule with the 
"Best Quality" template, you can use a video overlay that uses 50% of the layout along with 
one playlist and two tickers. If you increase the size of the overlay, you will need to reduce the 
number of playlists/tickers and/or use a different (lower quality) template. 
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Figure 16.  Add Content Block or Overlay 

Adding a Video Stream 

You must create a layout with a video stream (VSO) content block (see Adding Content 
Blocks and Overlays) in order to play streaming video in the block. Digital Signage supports 
only one VSO content block per layout. To configure the content block with video, you simply 
configure a stream in the Content Server with the URL of any VBrick (Windows Media or 
H.264) encoder on the network. The stream associated with the URL will then be pushed to 
the Signage Player—at which point there two different scenarios: 

• The Signage Player can connect directly to a TV or other device to play the stream 
locally. 

• The Signage Player can connect to a VBrick encoder to distribute the multicast stream 
over an IP network to set top boxes, PC desktops, Internet viewers, etc. The network 
diagram for this scenario is shown in Figure 4 on page 9. 

 To add a video stream: 

1. Add the Signage Player: 
a. Login to the Signage Player (see Login to the Channel Player on page 56). 
b. Go to the communications page (Figure 18) and configure the Player Name and IP 

Address or DHCP (recommended), and click OK. 
c. Go to the display page configure the Aspect Ratio to match the display device. For 

best results on widescreen, 16x9 devices, set to 1280x720. If outputing to an encoder, 
the encoder stream configuration should match these settings. 

2. Configure the Signage Player. 
a. In Digital Signage, go to Configure > Channel Players > Hardware and click Add. 
b. Enter a Player Name, Telnet port (default = 6500), and Aspect Ratio (this should 

match the setting on the Signage Player in previous step. Then click Finish and 
Refresh the page. 

Note When replacing a live stream url with a different live stream URL the best practice is 
to remove the stream Program Name and create a new one. Avoid using the "edit" 
option to replace the stream URL.
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c. Select the Signage Player you just added, check the Stream Window box, and click 
Change. 

3. Select a Layout.
a. Using the VBrick Desktop > Display Layout Editor, select a Signage Player and 

create a layout with a video stream overlay (VSO) content block (see Adding Content 
Blocks and Overlays on page 51).

b. Make sure the layout is saved and associated with a Signage Player. 
c. If adding a ticker, be aware that tickers cannot overlay the VSO content block. 

4. Configure the stream. 
a. Go to Now Playing > Streams. 
b. From the Display Server dropdown select a "Normal" layout (for example 

<player_name> : Normal) associated with the Signage Player you are configuring. 
c. Click Add Program and enter a Program Name, a Program URL, and a Schedule (see 

below). 
d. Reboot the Signage Player from the Configure > Channel Players > Hardware page.

5. Go to Configure > Channel Players > Layouts. Select the Signage Player, select a layout 
with a VSO content block, and click Apply to Player. 

Program Name Enter a name for the stream. This is used internally and not shown 
anywhere on the display.

Program URL Enter a URL in the format that corresponds to the encoder (Windows 
Media or H.264) or server (VOD-W, VOD-WM) type and your 
network configuration. See Supported URLs – Live Streams on 
page 26 or Supported URLs – Stored Streams on page 27 for a 
complete list of supported formats. 

Schedule Enter a schedule for the stream.
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Media Importer
Use this tool to select multiple media files and import them in a single batch not exceeding 
1.99 GB per import. You can import any of the media file types shown in Table 6 on page 19. 
Digital Signage stores the files in the Content Manager and they are accessible from the 
Manage pages. The files are stored by default in:

C:\Program Files\VBrick Digital Signage\Content Services\BinaryStorage\Upload

Figure 17.  Media Importer 

 To upload multiple files: 

1. Launch the tool and click Select Media Files. 
2. Select any supported file types not exceeding 1.99 GB. Use Ctrl or Shft-Click to select 

multiple files. 
3. For Background images, select an aspect ratio and a folder. 
4. Click Import to upload selected files to the Content Manager. 

Note For best results when streaming video, configure the H.264 or Windows Media 
encoder to use the "Best Quality" template. See the corresponding Windows Media or 
H.264 appliance Admin Guide for more information. 
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Overview 
The Channel Player is a small purpose-built device that receives high 
definition content over the IP network and displays it on plasma or LCD 
display. The Channel Player supports a wide variety of display resolutions 
allowing it to accommodate multiple types of displays and screen 
orientations. The output of the Channel Player can also be inputted into a 
High Definition VBrick encoding appliance to deliver a single stream 
over the network.

This topic explains how to configure and use a Channel Player after it has 
been added you your system. You add a Channel Player using the web 
interface (see Configure > Channel Players on page 37). To configure a 
Channel Player you will need to access the device by directly connecting a 
keyboard and mouse. 

Configuring the Channel Player
Channel Players must be added to the system and then configured. This topic explains how to 
configure a Channel Player. The topic Adding a Video Stream on page 52 explains in detail 
how to add a Channel Player. Once the Channel Player is installed and configured it is 
unlikely you will ever need to make changes. However, if necessary, you can use the page 
shown in Figure 18 to modify the configuration. Note that the number or character in parenthesis, 
after the menu item, is the keyboard shortcut for that item. After making configuration changes, 
always reboot the device using the keyboard shortcut. (You can also reboot a Channel Player 
from the web interface using the Configure > Channel Players > Hardware page.) 

Important Note The term "signage player" refers to the standalone devices that feed audio 
and video signals to LCDs, plasma displays, and other player devices. The terms "signage 
player" and "channel player" are used synonymously. We are transitioning to new 
terminology and there may still be legacy references to "channel player" in the application 
and in the online help.

Note To configure the Channel Player you must connect a keyboard and mouse directly to 
the USB ports on the device. You cannot use Remote Desktop. 
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Login to the Channel Player 

After logging in to the Channel Player Management console (Figure 18) for the first time, it's 
always a good idea to change the default login credentials for the console using the security 
(6) option as explained below. Also be aware that for proper operation, automatic login is 
required and is configured in the registry per Microsoft procedures. If you elect to change the 
Windows Administrator password, in order to maintain correct operation, you will also need 
to change the registry settings to support automatic login with Administrator credentials. 

 To login to the Channel Player console:

1. Plug a keyboard and mouse into the USB ports on the Channel Player.
2. Click anywhere on the page (except on the stream overlay) and press Esc.
3. Click on the moving window, and when prompted, login with user name = admin, 

password = admin 
4. This will display the Channel Player management console. 
5. When adding a Channel Player, you will need to click on communications (4) to enter a 

Player Name and IP Address.

Figure 18.   Channel Player Management Console

play Exit the management page and play the configured layout.

display (1) Sets the display resolution of the player. It should be set to match 
the resolution of the display device. The resolution of the display 
device must be set on the actual device itself. 

sound (3) Configure the audio output of the player.

communications (4) Set the Player Name. Enable DHCP or set the IP address of the 
player (default = DHCP).

date & time (5) Set the date and time or automatically acquire from Windows. 

security (6) Sets the login credentials (default = admin/admin) for accessing the 
Channel Player Management console (Figure 18). 
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Installing PowerPoint on a Channel Player
The Import > PowerPoint functionality lets you import .ppt/.pptx files directly to the 
Channel Player for PowerPoint playback in native mode. If you plan to import PowerPoint 
slide presentations, a registered copy of PowerPoint 2003, 2007 or 2010 must be installed on 
every Channel Player where the slides will be shown. If a Channel Player does not have 
PowerPoint installed, it will be skipped in the playlist. You will also need to disable error 
notification on each Channel Player for PowerPoint to work properly. See below Disabling 
Error Notification.

 To install PowerPoint on a Channel Player: 

1. To upload a standalone version of Microsoft PowerPoint or to upload PowerPoint from a 
bundled version of Microsoft Office, you first need to connect a mouse, keyboard and a 
display to your Channel Player. 

2. Navigate to the PowerPoint 2003 or 2007 or Microsoft Office installation files on a 
thumbdrive or a network folder. 
a. If installing a stand-alone version of PowerPoint 2003 or 2007, simply install the 

software provided on the disk. 
b. If you are using a Microsoft Office installation disk (bundled software), you will need 

to perform a custom install. You do not want to perform a complete installation. After 
selecting a Custom Installation, select the following programs in their respective 
check boxes: Microsoft PowerPoint, Office Shared Features, and Office Tools. You 
will need to select "Run all from my computer" and be sure to deselect all other 
Microsoft Office products. 

c. When prompted to register the software, you can (1) register via the web if you have 
Internet access, or (2) register by phone if you do not have Internet access.

3. If PowerPoint was not installed properly on the Channel Player, go to Control Panel > 
Add/Remove Programs, find Microsoft Office in the list and select the option to 
Change. Then repeat these steps. 

tuner (t) Not used.

statistics (s) View statistics for this device. 

command prompt (c) Exit to a command shell. To exit to the Windows desktop, type 
maintenancemode (one word) and press Enter.

firmware update (f) Do not use except as directed. 

logout (l) Logs out the current user.

shutdown (u) Shuts down the player. 

reboot (r) Reboots the player. When prompted, select Yes for Boot to 
playback. This will automatically start the player and skip the splash 
page shown in Figure 18. 

Note The Channel Player does not have a disk drive. To install PowerPoint you will need to 
copy the PowerPoint installation files to a thumbdrive or a network folder.
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Disabling Error Notification

Error notification will need to be disabled on each Channel Player that will play PowerPoint 
slides in order for native playback of PowerPoint to work properly. This will not prevent any 
errors from being logged, it only prevents the error notification from popping up on the 
screen if a presentation ends abruptly during a layout change or if the player is shut down. 

 To disable error reporting notification for Windows Server 2003 or Windows XP:

1. Go to Start > Run and type gpedit.msc 
2. Go to Computer Configuration > Administrative Templates > System > Error 

Reporting. 
3. Open Display Error Notification and set to disabled. 
4. Open Configure Error Reporting and set to enabled. 
5. Click OK, restart the computer, and you are done. 
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Software Upgrade
VBrick may periodically release a new version of the Content Manager software with updated 
functionality, bug fixes, and other enhancements. See the "Software Upgrade" topic in the 
Digital Signage Release Notes for complete upgrade instructions. 

Backup and Restore 
It is always a good idea to backup the content files on the Content Manager periodically using 
the VBrickBackup.bat utility. As explained below, there are two essential items you will need 
(the VBrickBackup.bak file and the BinaryStorage folder) to restore the content database if 
the hard drive or operating systems fails on the Content Manager. You will not be able to recover 
Digital Signage content data if you fail to backup both of these items. We recommend that you copy 
these files to an external drive and/or and store them in a safe environment. The frequency 
with which you backup the database depends on the frequency of the changes to your 
settings and content: the more often the content files change, the more often you may want 
to backup the database. The following instructions assume that: 

• Digital Signage software is installed to the default location on the Content Manager:

C:\Program Files\VBrick\Digital Signage\Content Services 

• SQL Server 2005 Express and SQL Server Management Studio Express are installed on 
the Content Manager. 

• You are familiar with Windows Server 2003/2008 and Microsoft SQL Server 
Management Studio Express. 

Notes • A database backup backs up the files on the Content Manager only—not the 
Signage Players.

• All VBrick and IIS services are stopped during a backup. Since this will interrupt 
streams on all Signage Players you may wish to run the backup during off peak 
hours. 

• You can only restore the database to a Content Manager running the same version 
of software on which the backup was made.
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Backing Up the Database

 To backup database content files: 

1. Obtain the VBrickBackup.bat utility from VBrick and manually place this file in the 
following folder: 

C:\Program Files\VBrick\Digital Signage\Content Services\Support 

2. Double-click on the VBrickBackup.bat utility file and run the file from the Support 
folder. This process will stop all Digital Signage services, backup the Digital Signage 
database, and create the BinaryStorage folder. When the backup is complete, it will 
create the following folder on the Content Manager: 

C:\VBrickBackup\VBrickBinaryStorage_<date/timestamp> 

Inside that folder, you will find a subfolder BinaryStorage that includes a file named 
VBrickBackup__.bak. These are the items you will need to restore the database if it ever 
becomes necessary. 

Restoring the Database

When restoring the database, you must restore the .bak file and the BinaryStorage folder at 
the same time. Also, as previously noted, you can only restore the database to a Content 
Manager running the same version of software on which the backup was made. 

 To restore the database using the previously saved files: 

1. Stop all VBrick Services. Go to Start > Programs > VBrick > Channel Player Utility. 
a. On the VBrick Services tab, click List Services. 
b. Wait for the list to populate, then select all services and click Stop Selected VBrick 

Services. 
2. Stop all IIS Services. Go to Start > Run and type iisreset /stop 
3. Launch the SQL Express 2005 Management Studio. Go to Start > Programs > Microsoft 

SQL Server 2005 > SQL Server Management Studio Express. 
a. Connect to the VBrick Database.
b. In the left navigation bar, click on Databases, then right-click on VBrick and go to 

Tasks > Restore. 
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c. On the General page, specify the Source for restore as From device and use the 
search control to navigate to the folder where you saved the .bak file, for example: 

C:\VBrickBackup\VBrickBinaryStorage_xxx\VBrickBackup_xxx.bak 

d. On the Options page, check Overwrite the existing database and Leave the database 
ready to use ... 

e. Then click OK and exit Microsoft SQL Server. 
4. Replace the old BinaryStorage folder with the backup copy as follows:

a. Go to the folder where you saved the .bak file, for example: 
C:\VBrickBackup\VBrickBinaryStorage_xxx\ and copy the subfolder named 
BinaryStorage. 
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b. Go to the installation folder: C:\Program Files\VBrick\Digital Signage\Content 
Services and replace the BinaryStorage folder there with the backup copy from 
previous step. 

5. Modify the access control permissions for the new BinaryStorage folder as follows: 
a. Right-click on the folder and select Properties. 
b. On the Security tab, select the Users group and click Edit Permissions. Then check 

Full Control and OK to exit. 
6. Reboot the Content Manager to start the VBrick and IIS Services and you are done. 

Activating a License Key 
All license keys you purchased are installed and activated before delivery. Use the following 
procedure only if you are installing a license that was not a part of your original purchase 
order. Once your requested License Keys have been delivered, you must activate the new keys 
before they take effect. 

 To activate a license key:

1. Copy the new license key files into the License folder. 
2. Go to Start > Programs > VBrick > License Manager. 
3. Click File > Activate Feature. 

4. Select I already have an activation key and click Next. 
5. Click Import Activation Key to import a key then click Activate. 
6. Repeat for all keys that require activation. 
7. Reboot the server for all changes to take effect. 

Changing the Splash Page Image 
If desired, you can change the logo on the Digital Signage "splash" page. This is the first page 
displayed after you launch the application from your browser. Any of the graphic file types 
typically supported by web browsers (for example .gif, .jpeg, .png, etc.) are supported. The 
maximum logo size supported by the login page is 450 pixels wide by 240 pixels high. The 
logo block is located along the left edge of the page, 335 pixels down from the top of the 
page. 

Note This procedure should only be performed by a qualified administrator or webmaster. 
Serious and possibly irreparable damage to the application can result if not done 
properly. 
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 To change the splash page logo:

1. Copy the desired logo file into the Logos directory which is typically: 

C:\Program Files\VBrick\Digital Signage\Content Services\Web 

2. Register the new logo file name with the Digital Signage Web application:
a. Open the web.config file in the Web installation directory with Notepad or another 

editor. 
b. Find the line that looks similar to: 

<add key="CustomImageName" value="tei_color_128.gif"/> 

c. Edit the value= parameter and insert the name of new logo file. 
3. All logos are horizontally aligned to the middle of the logo section of the page but their 

vertical alignment can be controlled as follows:
a. Open the web.config file in the Web installation directory with Notepad or another 

editor. 
b. Find the line that looks similar to: 

<add key="VAlignCustomImage" value="middle"/> 

c. Edit the value= parameter and insert one of the key words: top, middle or bottom. 

Changing the Navigation Tree Width
If desired you can change the default width of the navigation tree so you can see all menu 
items without scrolling. This procedure should only be performed by a qualified 
administrator or webmaster. Serious and possibly irreparable damage to the application can 
result if not done properly. 

 To change the tree width: 

1. Using Notepad or another editor, open the web.config file in the Web installation 
directory which is typically: 

C:\Program Files\VBrick\Digital Signage Content Services\Web 

2. Find the line that looks similar to:

<add key="NavigationPaneWidth" value="190"/> 

3. Edit the value= portion with an integer that represents the width of the navigation tree 
pane in pixels. 

Setting Automatic Windows Updates
It is standard VBrick policy to configure and ship our products with the recommended 
service packs and security updates available from Microsoft on the release date of the VBrick 
product. During product development, VBrick client and server applications are fully tested 
on the applicable operating system (Windows XP, Vista, Windows 7, Windows Server 2003, 
or Windows Server 2008) with the Microsoft service packs and updates available at that time. 
We also run limited regression tests when new service packs are released by Microsoft. Once 
installed at a customer site however, it becomes the customer's sole responsibility to continue 
installing security updates and patches as they become available. VBrick assumes no liability 
for damage resulting from the failure to patch your software. For best results, we recommend 
running all "automatic updates" (including Microsoft, Apple QuickTime, NVidia, and others) 
during off-peak hours when it will not affect users or impact performance. 
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Digital Signage Terminology 

Aspect Ratio The ratio of height and width. Be sure to use images that match the 
aspect ratio of your content blocks.
• 4:3 – universal standard for Standard Definition TV.
• 16:9 – universal standard for High Definition TV. 
• 9:16 – used for "portrait" layouts.

Background Graphic files behind bulletin text and graphics. Same as wallpaper. 
Can be used with layouts or bulletins. See also Wallpaper.

Boot Schedule The system automatically reboots once each week. This option on the 
Configure > Content Settings page lets you set the day and time. 

Bulletin Bulletins are created and scheduled to one or more playlists. Bulletins 
are created or imported, use backgrounds, play on one or more 
playlists, and can be scheduled for immediate or future play on 
endpoints.

Channel Player This term has been superseded by Signage Player.

Content Anything stored in the Content Manager and used for bulletins or 
tickers including basic text, static images, PowerPoint slides, video 
files, data feeds (news or weather tickers), etc.

Content Block Area on a display that contains playlists, tickers (crawl lists), and video 
windows. This image has four content blocks defined by the pixel 
width and height in display area. 

Content Manager The Content Manager hosts the Digital Signage application software, 
system database, and the browser-based user interface. The Content 
Manager does not provide bulletin display outputs—this is the role of 
the Signage Players.
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Crawl Crawls are scheduled to a crawl list or multiple crawl lists. A crawl 
consists of user-created text, news feeds, weather feeds. See also 
Ticker.

Crawl List Series of crawls (tickers). Designated to specific content blocks on the 
display.

Desktop 
Messenger

Delivers messaging directly to user desktops. Specified PC users in 
your network see messages as a graphic in a pop-up window or they 
can double-click for full screen or close with one click.

Digital Signage 
Desktop

Standalone application installed on user desktops. Consists of the 
following tools:
• Freeform Editor – used to create bulletins with any combination 

of text and graphics. 
• Template Editor – used to create bulletin templates with a 

preconfigured and consistent look-and-feel. 
• Display Layout Editor – used to create custom layouts for Signage 

Players.
• Media Importer – used to import files not exceeding 1.99 GB.

Displays Output devices attached to Signage Players, for example flat-panel 
displays, TVs, set top boxes, room signs, etc. 

Display Layout 
Editor

Part of Digital Signage Desktop. Used to create custom layouts for 
Signage Players. 

Endpoint Any supported display device e.g. plasmas, set top boxes, etc. 
connected to a Signage Player.

Free Form Editor Part of Digital Signage Desktop. Used to create bulletins with any 
combination of text and graphics.

Layout Layouts are specific to a signage player. Overall arrangement of 
content blocks in the display area. May include wallpapers and can be 
scheduled to change throughout the day or on specific week days. In a 
layout without wallpaper, the content blocks fill the screen. In a layout 
with wallpaper, the content blocks are placed over a background 
image. See also Template.

Mass Alert In the event of an emergency, Digital Signage suspends normal 
operation and sends a Mass Alert Notification to all Signage Players.

Media Importer Part of Digital Signage Desktop. Used to import files not exceeding 
1.99 GB. 
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Mode Determines how the application is set to run. To set the mode, go to 
System Tools > Change Mode. 
• Normal mode – used with playlists that have normal every-day 

content. In Normal Mode, the content and layout can change 
periodically. 

• Alert mode – used with playlists that broadcast alert, security, or 
emergency messages. Alert messages are not seen until you activate 
Alert Mode. Alert modes has one default layout and you cannot 
create additional layouts.

Now Playing This page shows the Play Lists, Tickers, and Streams that are currently 
scheduled to play.

Player Snapshots The Now Playing > Player Snapshots page shows a visual image of 
what is currently being displayed on each Signage Player. 

Playlist Consists of a series of bulletins, video, and/or other media files. 
Playlists are dedicated to specific content blocks on displays. 

Publishers Desktop Messenger or RSS. Pushes content to endpoints (e.g. Signage 
Players). 

Signage Player Signage Players are the units that create the video and audio signals for 
distribution and delivery to displays supported by a signal distribution 
infrastructure. They run on a custom embedded version of Windows 
XP, and provide video and audio connections on the back of the 
player (i.e. DVI, S-Video, Composite video, and VGA). Previously 
called the "channel player."

Template A template is a bulletin with preset images and/or formatting that can 
be used to quickly create a new bulletin with built-in quality controls. 
You can manage the various components in the bulletin template to 
match organizational themes. See also Layout. 

Template Editor Part of Digital Signage Desktop. Used to create bulletin templates 
with a preconfigured and consistent look-and-feel.

Ticker Tickers (running right-to-left or left-to-right) are scheduled to crawl 
lists. See also Crawl. 

VBrick News 
Service

A free news service, hosted by VBrick, that provides up-to-the-minute 
content for news bulletins and news tickers.

Video Stream The output from a VBrick encoder playing in a content block. Digital 
Signage supports the Windows Media and H.264 VBrick encoders. 

Video Stream 
Overlay (VSO) 

Requires a stream from a VBrick encoder. A video stream overlays a 
content block in the display layout. When scheduled, the video stream 
window will play over the content block or ticker. When not 
scheduled, the content block can be replaced by an image.

Wallpaper Background graphics that cover the entire display area. Same as 
background. Can be used with layouts or bulletins. See also 
Background. 
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Overview
VBrick's Digital Signage supports the integration of event data from Dean Evans & 
Associates, Inc. EMS® software. Before you can create bulletins that display events from the 
Dean Evans EMS software you must first configure the Dean Evans EMS Adapter. Once you 
have configured and tested the Dean Evans EMS Adapter you can create bulletins that 
contain the Dean Evans EMS events. Create > Event Schedule Bulletins details the steps you 
can take to create one or more event schedule bulletins. It is important to keep in mind that 
the Dean Evans EMS Adapter operates separately from the Event Schedule Plug-in, which 
automatically regenerates all event schedule bulletins. The Dean Evans EMS Adapter fills 
Digital Signage with events and the Event Schedule Plug-in uses those events to generate 
bulletins.

Step 1. Configure the Dean Evans EMS Adapter 
Go to Configure > Events > Deans Evans EMS Adapter in the Digital Signage web 
interface. The Dean Evans Adapter screen allows you to configure the Dean Evans EMS 
Adapter service that regularly copies events from the Dean Evans EMS database to the 
Digital Signage database. Once the events are copied to the Digital Signage database, the 
Digital Signage Event Schedule Plug-in creates bulletins from them automatically. 

Refresh Interval You can specify any value greater than 0. Recommended values 
include 15, 30 and 60. This controls how frequently the Dean 
Evans Adapter copies events from the Dean Evans EMS database 
to the Digital Signage database. The more frequently you update 
your Dean Evans EMS system the smaller this number should be. 
Note that bulletins are redrawn based on the regeneration interval 
specified in Content Settings - Event Management Plug-in, not on 
the refresh interval on this screen. 

EMS Version In order to configure the adapter you must tell it which version of 
EMS you are using. Supported versions include: Professional (11.x 
or higher) and Enterprise (5.x or higher). 
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Professional 8.x 
Location 

When you use Professional 8.x, you must tell Digital Signage 
where the Dean Evans EMS database is on the network. You 
should use UNC paths, as in: 
\\myserver\myshare\mydir\prodat40.mdb 

Enterprise/
Professional 9.x SQL 
Server 

When you use Enterprise 2.x, 3.x or Professional 9.x, you must 
tell Digital Signage the name of the SQL Server computer. This 
name can be a DNS name or address. Consult your network 
administrator for help.   Professional 9.x Note: Professional 9.x 
uses a "named" instance of SQL Server by default. This means 
you will have to enter the SQL Server name in the following form:   
computer-name\sql-instance-name 

SQL Database After you specify the name of the SQL Server computer you must 
give the name of the database on the server. Consult your DBA 
(Database Administrator) for help. 

Windows Authentication Choose Yes or No based on the way the SQL Server Database is 
configured to allow logins. Consult your network and database 
administrators. 

SQL User ID If you are not using Windows Authentication then you need to 
provide the SQL User ID. Consult your DBA for help. 

Save Password If you are not using Windows Authentication then you need to 
provide the SQL Password and click Save Password. Consult your 
DBA for help. 

Connect Once you have set all the information that Digital Signage needs 
to find and communicate with the Dean Evans EMS® database 
you can test the connection by clicking Connect. If any errors 
occur then you will be given those connection errors on your 
screen so you can get assistance from the network or database 
administrators. If no errors occur then the lower portion of the 
screen will contain the Event Rooms, Types and Statuses found in 
the Dean Evans EMS® Database. 

Excluded In order to exclude rooms, types and statuses you highlight items 
in the appropriate Included list and click the < button to the left 
of the list. 

Included In order to include rooms, types and statuses you highlight items 
in the appropriate Excluded list and click the > button to the right 
of the list. 

Click > to include 
selected excluded 
items.

Click < to exclude selected included items. 

Finished Once you have configured the Dean Evans EMS® Adapter you 
can click Finish to go back to the menu. 
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Step 2. Dean Evans Adapter Import
The Dean Evans Adapter Import screen shows you the result of importing events 
immediately from the Dean Evans EMS database configured for the Dean Evans EMS 
Adapter. If there are any errors communicating with the database they are displayed so that 
you can consult your network or database administrator. If events are found and qualify 
based on the filters you establish in the Dean Evans EMS Adapter setup, then the import 
screen displays status in the form. Regardless of whether any rows were found to import you 
can click the Back button to go to the Dean Evans EMS Adapter screen to configure the 
adapter or click Finished to go back to the menu.

Step 3. Configure Event Management Plugin 
Go to Configure > Content Settings > Event Management Plugin in the Digital Signage web 
interface. The Event Management Plug-in section of the Configure Content Settings screen 
allows you to configure the Digital Signage Event Schedule Plug-in, a service that generates 
bulletins automatically based on settings established by the Create Event Schedule Bulletin 
screen. The service regenerates all bulletins automatically so that all events displayed in the 
bulletins are relevant based on the time of day. 
 

Import Now If you want to test the connection and your selected filters you 
can import events immediately by clicking Import Now. If the 
import works you will be shown all the events that were imported. 
If any errors occur communicating with the database they will be 
displayed so you can give them to your network or database 
administrator. 

Save Plugin Settings After changing settings you can save them immediately by clicking 
Save Plug-in Settings. 

Regenerate Bulletins 
Every 

Perhaps the most important setting, this specifies how many 
minutes the service should wait between generating/regenerating all 
bulletins for all groups established under Bulletins | Create Event 
Schedule. The value must be between 1 and 59. 

Default Aspect Ratio Choose the default aspect ratio used when a user enters the Bulletins 
> Create Event Schedule screen. 

Default Background Choose the default background image used when a user enters the 
Bulletins > Create Event Schedule screen. 

Default Audio Choose the default background audio used when a user enters the 
Bulletins > Create Event Schedule screen. 
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Step 4. Create Event Schedule Bulletin

Create Event Schedule Bulletin – Part 1 

Go to Create > Event Schedule Bulletin in the Digital Signage web interface. The Create 
Event Schedule Bulletin screen allows you to create a group of bulletins that is automatically 
refreshed by the Event Schedule Plug-in to display current or future events. The events can 
come from Digital Signage or from an external Event Management System. The first step in 
creating an event schedule bulletin group is to define the attributes of events you want to 
include in the group. 
 

Group Name Since you can create as many event schedule bulletin groups as you 
wish you need to provide a name to distinguish them once they've 
been scheduled in playlists. This name is also visible in My Content. 

Limit to n Bulletins Regardless of how many events qualify according to your filtering 
criteria you can limit the number of bulletins generated to a specific 
number 1 - 10 OR you can leave the count unlimited. 

Start The default for filtering events is to gather events that start today. 
You can change the start day by days or weeks using the dropdown 
list. 

Display Next ... The default is to show events that start Today through the next 0 
days (which means only show Today's events). Just as you can have 
the Event Schedule Plug-in gather events that start today (or days or 
weeks after today) you can also control the time span to cut off by 
picking a number of days, hours or weeks. 

Current Time The current system time on the main Digital Signage server. 

Adjust Time By ... If you are gathering events that are for a different time zone than 
the system then you can use this adjustment value (-12 through +12 
hours). 

Message Importance This option applies only to Enterprise licensed systems. It has no effect 
unless Multi-Tier Player Publishing is enabled with Message 
Importance. This setting controls the relative order in which 
messages are distributed to players. 

Stop Displaying 
Event ...

Events normally display on bulletins until the end time has elapsed. 
You can limit how long an event is displayed by checking Stop 
Displaying Event below and specifying a time span. The event will 
stop displaying when either the end time has elapsed or the limit you 
impose has elapsed, whichever comes first. 

Filter Rooms Filter Statuses

Filter Types You can optionally filter by Rooms, Event Statuses and Event Types. 
If you choose to filter by one or more of these criteria you must 
explicitly include items, using the controls described below. 

 Excluded If you filter Rooms, Event Statuses or Event Types, the Event 
Schedule Plug-in determines which events to gather partially based 
on the filtering. By default, all rooms, statuses and types are 
Excluded. To mark one as included you select it in the appropriate 
Excluded list, then click the > include button. 
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Create Event Schedule Bulletin – Part 2

The Create Event Schedule Bulletin screen allows you to create a group of bulletins that is 
automatically refreshed by the Event Schedule Plug-in to display current or future events. 
The events can come from Digital Signage or from an external Event Management System. 
The second step in creating an event schedule bulletin group is to change the visual attributes 
of the bulletins from their defaults (unless you don't want to change anything). 

> Includes a selected 
item from the list to 
the button's left

< Excludes a selected item from the list to the button's right 

 Included If you decide to exclude a selected Room, Event Status or Event 
Type you must select it in the appropriate Included list and click the 
< exclude button. 

 Preview You can force a regeneration of the preview bulletin(s) at any time 
by clicking Preview. 

As you change the selection criteria for events the preview 
thumbnails are automatically regenerated by the Event Schedule 
Plug-in. On step 1 you cannot control the visual properties (font 
sizes, colors, and placement). Step 2 is concerned with the visual 
properties of the bulletin group. 

 Cancel | Next Once you are satisfied with the definition of the event group (its 
selection criteria) you can click Next to change format settings, or 
click Cancel to go back to the menu (and lose all your changes). 

Group Name Since you can create as many event schedules bulletin groups as you 
wish you need to provide a name to distinguish them once they've 
been scheduled in playlists. This name is also visible in My Content. 

Aspect Ratio You can choose any available Aspect Ratio. 

Background You can choose any Background image that is available for the 
Aspect Ratio you've chosen. 

Audio You can choose any background Audio file. It will play for every 
bulletin defined by the group. 

Show Date Using ... If you want a date block displayed on every bulletin you can check 
the Show Date box and pick a date format. The Top and Left values 
are in pixels relative to the dimensions of the Aspect Ratio chosen. 
In this sample the Top is 5 units down from the top out of 600 units 
and the Left is 5 units to the right out of 800 units. 

Fonts All blocks (Date, Title, Events, Locations, Cancelled Events, and 
Time) allow you to specify the rendition of the font: Bold, Italic, 
Underline and Strikethrough. 

Font Color Many blocks (Date, Title, Events, Locations, and Time) allow you to 
specify the font color, name and size. 
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Show the Title If you want a title block displayed on every bulletin you can check 
the Show the Title box and enter title text. The Top and Left values 
are in pixels relative to the dimensions of the Aspect Ratio chosen. 
In this sample the Top is 5 units down from the top out of 600 units 
and the Left is 5 units to the right out of 800 units. 

Event Attributes You can specify the font attributes and the boundaries of the event 
block. 

Event Location 
Attributes 

You can specify the font attributes and the left boundary of the 
locations. This is normally used to indent the locations under the 
events. 

Include Building 
Name

If you want the building name to display beside the room name, 
check the box. 

Cancelled Event 
Attributes 

You can specify the font rendition for cancelled events - to visually 
differentiate them from NON-cancelled events. 

Times Uses You can control the time format by choosing a format from the 
dropdown list. 

Bulletin Pacing The Event Schedule plug-in regenerates all event schedule bulletins 
on a regular basis. When it regenerates them, it reapplies them to all 
playlists. The contents of the bulletins are likely to change so the 
system can calculate the pacing for you. If you don't want automatic 
pacing then select an appropriate number of seconds. Each bulletin 
will use the number of seconds you specify. 

Group Padding Padding is blank space that vertically separates one even from 
another, or one start time from another. Padding is used to make 
text easier to read. The number you enter represents pixels relative 
to the dimensions of the Aspect Ratio chosen. 

Text for NO 
EVENTS 

There is always the possibility that NO EVENTS will match your 
selection criteria from Step 1 at any given point in the future, so you 
must specify the text to display when this happens. 

Preview You can force a regeneration of the preview bulletin(s) at any time 
by clicking Preview. 

 

As you change the visual settings the preview thumbnails are 
automatically regenerated by the Event Schedule Plug-in. 

Cancel If you wish to disregard all your changes and go back to the menu or 
previous screen you can click Cancel. 

Back | Next If you wish to change your selection criteria you can click Back. 
Once everything is set the way you want it you can click Next to 
schedule the bulletin group on one or more playlists, depending 
upon your privileges. 
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Appendix B
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Overview 
The Mass Alert Notification feature allows alert messages to be delivered and displayed on 
every Digital Signage endpoint reachable by the Digital Signage Content Manager. If the 
Digital Signage Mass Alert Notification license has been activated on your system, the feature 
is visible in the Digital Signage License Manager application, located on the Digital Signage 
Content Manager. If you would like to purchase this feature, please contact VBrick Support 
Services for assistance.

Triggering Methods

As shown below, there are three ways to trigger Mass Alert Notification. Detailed 
descriptions for the three options are provided below. Each of the options require an Digital 
Signage system administrator to configure the Mass Alert Notification screen in the Digital 
Signage web interface (Configure > Mass Alert Notification), in addition to the specific 
configurations required by each of the three options. The instructions are provided at the end 
of this document for the Mass Alert Notification screen.

• Manually (from the Web Interface) 
• CAP Alert (XML message, e.g. e2Campus) 
• Email Trigger 
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Manually (from the Web Interface)
Manual mass alert activation is accessible to an Digital Signage System Administrator from 
the Welcome screen in the web interface. A user with the System Administrator role may log 
into the Digital Signage web interface and activate mass alert notification from the Welcome 
screen by selecting the Activate Mass Alert Notification button.

This action opens a new screen and requires the administrator to select from a pre-defined 
list of alert categories. The categories in the drop-down menu are defined by OASIS, the 
organization responsible for CAP alert standards.

The alert categories are as follows:

• General Alert
• Fire
• Severe Weather
• Acts of Violence
• Earthquake
• Safety
• Rescue
• Public Health
• Pollution
• Transportation
• Infrastructure (includes cyber threats)
• Mass Destruction
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Each alert category includes a predefined background image and text that will be displayed 
automatically when the “Enable Mass Alert” button is selected on this screen. If the 
administrator chooses a category, but does not include any text in the “Alert Text” field, and 
clicks the “Enable Mass Alert” button, the predefined background and text will appear on all 
players that are actively reachable by the Digital Signage Content Manager. The default text 
may be customized under the Configure > Mass Alert Notification screen. The administrator 
may choose to enter a message in the “Alert Text” field, which will play instead of the text 
that was customized under Configure > Mass Alert Notification.

Once the “Enable Mass Alert” button is selected, a new screen appears, allowing the 
administrator the following actions: 

The administrator will be returned to the Digital Signage Welcome screen once the alert is 
deactivated on all active players. If an Digital Signage user without the System Administrator 
role attempts to log into the web interface when Mass Alert Notification is active, they will 
see a message in their browser that states “Mass Alert Notification is on” in place of the 
Welcome screen. Only an Digital Signage user with the System Administrator role is able to 
activate, enter, replace and/or append alert text and deactivate the mass alert notification. 
The Mass Alert Notification will continue until an intentional action is taken to stop it. This 
interaction can be prompted by an authorized user by selecting the “Disable Mass Alert” 
button.

Append Message Enter a new message to supplement the existing message.

Replace Message Enter a new message that will replace the existing message.

Disable Mass Alert Disabling the mass alert notification will stop playback of mass alert 
notification content on all players reachable on the network by the 
Digital Signage content manager.
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CAP Alert 
The Digital Signage Mass Alert Notification module includes a CAP Listener that may be 
installed on a PC or server separate from the Digital Signage Content Manager. This is useful 
because the CAP Listener often needs to be on a PC or server with a public IP address in 
order to receive information from a third-party vendor. The VBrick CAP Listener is 
expecting an HTTP post from the third-party vendor, and the HTTP post should be sent to 
the URL of the CAP Listener. The format for the URL is as follows:

//CustomerCAPListener/MassNotificationListener.aspx

The Digital Signage Web Configuration Utility is used to set the CAP Listener DNS/IP and 
listening port. Once the CAP listener application is successfully installed on its own 
dedicated PC or server, and available on the network (with the Digital Signage Content 
Manager), the Digital Signage Web Configuration Utility may be launched from the Digital 
Signage Content Manager. On the Digital Signage Content Manager, go to: Start > All 
Programs > VBrick > Configure CAP API. Enter the following information in the text fields 
provided:

Running this utility will signal to the listener what port to listen for requests. When a request 
is received, a series of checks for proper formatting is performed. If the request is properly 
formatted, an HTTP status of success will be returned, and the Content Manager will be 
notified to deliver the CAP alert.

Required CAP XML Information

1. Proper formatting in accordance to the CAP specification
2. Information needed for Digital Signage

a. Identifier - required
b. Message Type (Alert, Update, Cancel) – required
c. Category (i.e. Fire, Earthquake, etc.) – required
d. Reference to identifier – required if the request is a cancel

Application Server The name of the server where CAP Listener resides.

Application Port The port number the listener will monitor for CAP posts.

Website Title Any title can be entered here.



Mass Alert Notification

VBrick Digital Signage Quick Start 79

Optional CAP Information

Digital Signage contains default alert text for each alert type. Customers can override the 
default alert text and create their own custom alert message by using any or all of the 
following fields. VBrick is dependent on the third party vendor including one of more fields 
in the HTTP post in order for a custom alert message to be displayed:

1. Headline
2. Description
3. Instruction
4. Web
5. Contact

The above five fields will be a single, concatenated string that becomes the alert message text. 
Each field is separated by a single space only. There is no additional formatting provided in 
Digital Signage. For example: 

Headline = Urgent Severe Storm 
WarningInstruction = Take Cover Immediately!!

If the fields are entered as above, the alert text would read:

Urgent Severe Storm Warning Take Cover Immediately!! 

Additional Configuration Options

In order to use any or all of the five additional fields described above (headline, description, 
instruction, web and contact) as the alert message, an Digital Signage administrator must 
indicate which of the five fields will be included in the text. This is done through the Digital 
Signage web interface, under Configure > Mass Alert Notification in the “CAP Mass Alert 
Notification Configuration” section on the bottom of the screen. Administrators may select 
the box to the left of the field name for any or all of the fields to be included in the alert text 
message.

Email Trigger
For Email Mass Alert Notification Configuration, the following information is required to 
successfully complete configuration on this screen: 

1. You must configure the POP server email settings under Configure | Content Settings | 
Email Plug-in

2. You must provide a valid Pop Server email account (requires a Network or IT 
Administrator to create and provide an Digital Signage administrator with the email 
address and password) (e.g. fire@company.com; severeweather@university.edu). 

3. The e-mail address must be added to an existing or new Digital Signage User Account, 
which you may configure by going to Configure > Security > Users.
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1. Enter the valid email account and password information in the text fields provided.
2. Select the Mass Alert Type you wish to assign to this e-mail address
3. Repeat this step for each alert category you want to be triggered by an email address. 

Configuring a Mass Alert Notification
Each of the three options available to trigger Mass Alert Notification in Digital Signage 
require configuration in the Digital Signage web interface, in addition to option-specific 
configuration. A Digital Signage user with the System Administrator role may access this 
screen by going to Configure > Mass Alert Notification.

Ignore Alert 
Priority

Checking this box will allow the system to ignore Alert Priority when 
processing multiple alert triggers.
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Alert Type A letter is used to represent the Name and Type of alert.

Alert Name These Alert Types, Names and Modes are prepackaged with the 
Digital Signage installer.

Alert Priority Order in which the Mass Alerts are to be shown based on the 
importance level of mass alert (1 is highest priority).

Play Mode The mode is the type to be used by the system when Mass Alert 
Notification is triggered.

Replace Text Flag Check this box if you wish the last mass alert notification text to 
replace the default text.

Alert Style Choose the style of the alert text - none (default), scroll (playing 
across the screen, right to left) and blink (text will blink on and off).

Default Dwell The time (in seconds) that the Mass Alert Notification plays before 
repeating. NOTE: Caution must be taken when using the Alert Type 
'Scroll'. The Dwell time must be set to allow for the entire message to 
play before repeating.

Default Text: This is the default text that will play when no message is entered in the 
Alert Text field when activation has been launched from the Welcome 
screen.

Last Alert Text If text was added/changed/modified when you activated a Mass Alert, 
the last text entered will show here.

Reset If you wish to reset the Alert Types that came with your system to 
their default settings, you can use the button. Warning: Pressing this 
button will permanently delete any and all information you have 
changed for these types.

Email Mass Alert Notification Configuration See Email Trigger on page 79.

CAP Mass Alert Notification Configuration See CAP Alert  on page 78.
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Mass Alert Notification Layouts
The Digital Signage System Administrator may access the predefined Mass Alert Notification 
layouts using the Digital Signage Display Layout Editor. VBrick strongly recommends that 
the default Mass Alert Notification Layouts not be changed because the default content 
background is set specifically for the default location of the Alert content (text) block. These 
locations are: Bottom of Layout for Widescreen (16:9); Middle of Layout for Normal (4:3) 
and Middle of Layout for Portrait (9:16) aspect ratios. Any changes to the default Mass Alert 
Layouts should be thoroughly tested for all categories and aspect ratios.

Text Color This menu allows the user to change the text color of your Mass Alert 
Notification message.

BG Color This menu allows the user to change the background color of the 
Mass Alert Notification message.

Blink Color This menu allows the user to change the text color of your Mass Alert 
Notification message when the Alert Style is set to Blink.

Blink BG Color This menu allows the user to change the background color of the 
Mass Alert Notification when the Alert Style is set to Blink.
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Appendix C

Wayfinding
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Overview
Wayfinding is an interactive digital signage mapping application that is available on the 
VBrick Digital Signage system. Wayfinding solutions can span the spectrum of simple 
internet map-based solutions which show campus start and end points to multi-level 
in-building routing solutions. VBrick's Wayfinding solution is highly customizable. The 
screen can be filled with the map's image or other high value content can be added, for 
example animated clocks, weather and news modules, scheduled notices and graphics, and 
video feeds. This enables the Wayfinding display to be more than just a map. Figure 19 shows 
a digital sign that implements wayfinding. If you click a name in the Name Directory on the 
right, you will quickly see where that person's office is located in the floorplan on the left.

Figure 19.  Typical Wayfinding Application
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As part of the Wayfinding solution, VBrick will work with the customer to define the type of 
signage application and the level of customization required to produce the relevant digital 
sign. VBrick will produce a Statement of Work (SOW) which will include an outline of the 
tasks required, the delivery schedule, and the fees associated with the custom work. Once 
reviewed and approved by the customer, the customization work will commence.

Key Features

• Wayfinding spans the entire "wayfinding" solution from showing the way on Google 
Maps to providing multi-level building wayfinding including:
• Point to point navigation in a campus
• Room finding within a building
• Route indication within a building

• In addition to the map, the display can include:
• Animated clocks
• Weather and news modules
• Scheduled notices and graphical information
• Video feeds

• Custom content creation includes:
• Logos
• Color schemes
• Map and building representation

• Core Features include:
• Customizable content and branding
• Data feeds for AccuWeather, News, and RSS
• Touch-screen support

Wayfinding Configuration
This topic briefly describes how to configure a typical Wayfinding solution. The unique 
components of this particular Wayfinding configuration include a Flash file and two 
supporting data folders. The Flash file on the Signage Player must be able to access the data 
folders. In this example, the data folders will be placed on the Signage Player. In most cases 
you will need to use a dedicated Signage Player and a dedicated playlist. 

 To configure this wayfinding solution:

1. Import the Wayfinding Flash file (.swf) to the Digital Signage Video library (go to 
Manage > Video Files). 

2. Create a Wayfinding media bulletin using the imported Flash file (go to Create > Media 
Bulletin). 

3. Schedule the Wayfinding bulletin to play forever, all day long, in the dedicated playlist 
and ensure it is the only item in the playlist.

Note This configuration procedure is only an example, and will likely be different from 
the solution implemented at your site. Depending on your unique requirements, any 
required data may be located on the Signage Player, the Content Manager, a network 
location, on the Internet, etc.
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4. Configure a layout on the dedicated player to contain only one content block, full screen, 
displaying the contents of the dedicated playlist (go to Configure > Channel Player > 
Layouts, or use the VBrick Desktop).

5. Apply the layout to the dedicated player (go to Configure > Channel Players >Layouts). 
6. Determine the location of the Flash file on the player in the AxisTV.atd file on the 

Signage Player. It will usually be located in the Uploads folder: 

VBrick Channel Player\Data\BinaryStorage\Uploads 

7. Copy the supporting date folders, com and Data, and all of their contents, to the same 
folder as the Flash file on the player. 

8. Reboot the player when finished and you are done.
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